how to map document values to add transformer....

Hi all,
unable to add two numbers…
I had one xml file.

<?xml version="1.0" encoding="UTF-8"?>


  1. i converted this xml file to node
    2)node to document.
    3)then i mapped document values to add transformer input…and res output to result string…
    and then i traced here i am getting error…

can any body tell me the reason…

Everything looks fine here … just thinking how you get the document values.Did you create another document which conforms the original xml document and mapped to service input?
You can try using the variable substitution method instead of direct mapping from the doc to service input and check if it is working…



Hi Amol,
thanks for ur response…yes i created another document…and i mapped from xml conversion doc to which i created…and when i am tracing with debug log…i am able to get the values…
the problem is when i mapping this values to add transformer…these values is not going to transformer values…in this step only i am getting error…what is problem i am not getting…

hope for solution…

I’ve had a similar error, I think. In my case it was due to nodeToDocument added namespace prefixes on each element, i.e. Instead of “document/Values/a” it became “document/tns:Values/tns:a” or something like that. If you look closely in debug mode and you see this namespace prefix then you have the same error and you will have to add this prefix to the document that you have created.


Hi, can you upload the sample code you are trying to run ?

Before mapping it to the transformer please map the values to some x and y variables to see if the values are in the document.

a--------------------- x
b--------------------- y

if there are no vaues in the pipeline for x and y then there is something wrong in the DT…may be because of some referencing issues.

Hi Savanigadda,
As you mentioned i tried to map document values to x and y variables.while tracing i am able to see document values…but i am unable to get documnt values to x, Y Variables…Can you please help me to solve this issue.

Please post the details of each step being performed. You’ve mentioned a couple of times that you’re getting an error–what is the error?

Hi Reamon,
I am getting the Java.lang.numberFormat Exception…

Can you pls send a snapshot of your code ? wondering why numberFormat exception in just mapping to x,y variables ?

btw which version of wm ?


That exception will be because you’re probably passing an empty string to the add service. Your previous post mention you’re unable to get the values from the source document. Resolve that and the exception should go away.


And the source document sample.

Without that we’ll continue to go back and forth in this forum without much progress.