How to Ignore self signed certificate

Hi All,

I am trying to do a “get” call by hitting “https://URL:9001/xyz” link. It is Enovia CAS server. i am passing all parameters correctly but getting below error.

Error Message:

400 Bad Request

Bad Request

Your browser sent a request that this server could not understand.

I am using pub.client:http service to hit above link. Other team is telling to bypass self signed certificate and send request. So please may i know how do i ignore or bypass self signed certificate.

Are you able to call the url via SOAP/Postman with the same request payload?

Hi Mahesh,

In postman it works on turning off ‘SSL certificate verification’ in Settings > General

In webmethods were do i ignore those self signed ssl certificates.

Thanks in advance

Can you send the logs from your server.log during the client http call.

in the extended settings, you can set:
watt.security.cert.wmChainVerifier.trustByDefault=true
the IS will trust all certs. --> very risky though.
or, you can just get the self-signed cert and put them into your trust store.