How to force IO adapter to use another java version

Hi all,

I am running a I/O adapter on a solaris box, I want to force the adapter to use another version of java let say 1.4. How to do this. And also how to check the adapter is using the forced version of java.

Thanks,
Muru

you may have to take a look at adapter config doc and use adapter manager to monitor adapter process and check the version of jave.

you may have to take a look at adapter config doc and use adapter manager to monitor adapter process and check the version of java.

Muru,
Need to check few things from you on this question:

  1. DO you want the IO Adapter only to use a different version of jdk?

  2. OR DO you want all adapters to use a different version of jdk?

To answer
Q1: you could install the IO Adapter in a different workstation with its own wment41 folder having the java folder. Replace the contents of the java with newer version of jdk. This helps the adapter to pick up the latest version of Java.

Q2: stop all services - adapter monitor and broker monitor. Then replace the java folder with newer version of the jdk’s java.

Hope this helps.

Just a minor caution.

I use IO Adapter 4.2 on Win2000 Server. I replaced wment41\java with jdk 1.3.1_04. Everything ran OK at first, but my adapter monitor became unstable and started crashing seemingly at random. It could run for 3 days then crash 4 times in one day (I never found the cause). I reverted back to jdk 1.2.2 that came with the original install, and my adapter monitor has been stable ever since. Of course, this is on Windows so it may not apply on Solaris.

Just to add to Darrel’s post … I too have ran into a issue with replacing the wment41\java with jdk1.3.1_06.

I have been working with wM support and found out there is a known bug (id #4323062 - JavaSoft) with versions 1.3.0 and 1.3.1 running on NT/2000 server.

The bug kills java processes when a user logs off. In my case the Adapter Monitor service would shutdown every time I logged off the server.

Support suggests going back to version 1.2.2.

My answer came from one of the wM Support guys, we tried in dev and staging. It worked fine, so we have started to use in Production tooo…

No probs here at all.

I am not sure of the kind of probs you guys are seeing, but we do log off and log on quite a bit on our dev/staging boxes and none of our developers have cried for HELP.

You may have to make sure that you have stopped the services, replaces the java jdk and then restart the services.

Hello,

I would like to know what is the latest version of WebMethods enterprise ?

Thanks for your reply !

Jean-Baptiste