How to edit "Pull from Broker" document?

A document is pulled from Broker. Can someone suggest how to make it editable?

I am unable to add element in document type, even if I locked it. More in attached document. [Apologies for not a good image. It is to hide the doucment details].

Thanks in advance.

Rankesh
Document Type.png

Assume if it is a publishable document type, make publishable property to “false” and add the elements you need and then make publishable to “true”

Sync document to broker.

Thanks Mahesh.

Following worked for me:

I got the property in designer, called linked to source which needs to set as false.

Your screen showed up developer anyways thanks for your update and good information take away :slight_smile:

Hi Rankesh,
You got that right. Just to add few more detail.

‘link to source’ property will be set to ‘true’ whenever you have IS document created by various sources such as XML, XSD, Broker Publishable doc, WSDL, Flat file schema etc., All these generated documents would adhere to the schema that is attached with the created IS documents… Even if you do ‘Lock for Edit’, where you will see ‘green tick’ as if like editable, you wouldn’t be able to edit these generated IS docs. This is because, the generated document is linked to a schema & changes are not permitted in it, thus Designer doesn’t allow you to change it directly.

As you rightly found, setting ‘link to source’ property to ‘false’ will allow you to ‘edit and change document’, however it will give you a warning that, this document is no more tied with ‘schema’.

Hope this helps
-Senthil

1 Like

Thanks Senthil.

I assumed that this facility [linked to source] has come in version 9 :roll: . I was on developer not on designer. Later, I identified it when I logged in to designer. :idea:

Small correction this option is there from wM 8.2 on-wards in designer. I understand Rankesh why you did not find it in 8.2 :slight_smile: as you were using developer only :slight_smile:

Sounds a good humor here :smiley: