how to configure JDBC Adapter for SQLServer 2008

Hi All,

I would like to know whether I am giving proper information when setting up JDBC connection to SQL Server.

I have copied the jar files msutil.jar, msbase.jar and mssqlserver.jar under …/IntegrationServer/packages/WmJDBCAdapter/code/jars/static/ and restarted the server.

Other than the above jar files, do i need to install any other jars?

In the connection details, I am using datasource class as and providing servername, databasename, userid, pw, port,

What should i mention in Network Protocal and OtherProperties? Please let me know.

Best Regards,

I’m getting the following error:

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource Connections.jdbc:Test1.
[ART.118.5063] Adapter Runtime (Connection): Unable to start connection Connections.jdbc:Test1: after 1 attempt(s).
[ADA.1.204] Cannot connect to the database with DataSource class “”.
[Microsoft][SQLServer 2000 Driver for JDBC][SQLServer]Login failed for user ‘ABCD’.

Any help, please let me know. I’m still getting the same error. The server is SQL Server 2008 R2.( I given wrong info…in my original thread)

Can you check whether you are using the proper drivers for SQL Server 2008. your error log says “SQLServer 2000 Driver for JDBC”

Yes. The drivers are proper. I have msbase.jar, msutil.jar and mssqlserver.jar under /static/ folder.

Now, I have changed the datasource class to: Now, I am getting the below error.

[ADA.1.204] Cannot connect to the database with DataSource class “”.
Login failed for user ‘ABCD’.

What should i give in the datasource class? how can i determine what to use in this field. Any inputs are much appreciated.

Check if credentials are correct…

The credentials are correct as well. But still getting cannot login error.

Here are the connection details again. The server is SQL Server 2008 R2.

DataSource Class:
Servername: abcdefgh
port: 2866
user: ABCD
pw: ****
database: test
networkProtocal: TCP
Other Properties: Left blank.

Did not enable: connection Pooling [ I would like to enable after the connection is setup ]

The jar files which are already in place are msbase.jar, msutil.jar, mssqlserver.jar and sqljdbc.jar under /IntegrationServer/packages/WmJDBCAdapter/code/jars/static/

and sl53_cj34.jar under IntegrationServer/lib/jars/.

But I still get the same error as above. Can someone let me know what might be missing. Is it the login credentials or any jar file missing?

Hello David,

I am getting the same error as above.

Can you please let me know how you resolved it!

Thanks in advance…

If it is Login failed error, make sure you are using the correct user name and password to login. You can paste the exact error message you are getting…


I’m getting the below error, when im trying to connect to SQL Server 2008. We are using wM 9.7

[ADA.1.204] Cannot connect to the database with DataSource class “”.
SQL Server version 8 is not supported by this driver.

Any quick help is really appreciated.

Please check for latest Driver from Microsoft (Version 4.1.5605.100 or newer).

Alternatively you can try to use the embedded DataDirect-Driver (common/llib/ext/dd-cjdbc.jar).
See Settings->JDBC-Pools for a Sample how the Connection can be configured.


Do you have sqljdbc4.jar placed in the below locations: Restart IS


*************Issue Resolved *************

I have installed these jar files and gave the properties below:

The jar files required:

  1. mssqlserver.jar
  2. msbase.jar
  3. msutil.jar

Copy the jar files and place them in \instances\default\packages\WmJDBCAdapter\code\jars\static

Data Source Class:
serverName :
user : XYZ
password : ****
portNumber :1433
Other Properties
Connection Management Properties
Enable Connection Pooling false


Correction: Copy all the jar files to \instances\default\lib\jars

i am getting the same error while setting up sql connection, any one can help?

i am getting this exact error “Connection refused (Connection refused). Verify the connection properties, check that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port, and that no firewall is blocking TCP connections to the port”


Check if that user is allowed to do a remote login.
Use another DB client from your PC to check (SQuirreL, Database Browser, etc.).

Is it a DB user or an AD user? In the later case you need to configure other properties.

Maybe you also need to add the “instance=instance_name” parameter on Other Properties.

Best regards,