HELP!!!|SAP Adaper 4.6 problem| Upgrade|Unicode\Root Tag

Hi All,

We are using SAP Adapter 4.6 with SP5 to connect to a recently upgraded ECC6.0 SAP Unicode system. We have enabled the unicode settings in SAP Adapter too.

System details:
===========

Integration Server
------------------
Product webMethods Integration Server Version 6.5 Updates Server Chinese Language Pack
IS_6-5_SP2_FlatFile_Fix3
IS_6-5_SP2
TNS_6-5_SP1
Build Number 395 SSL Strong (128-bit)

SAP Adapter
-------------
Product webMethods B2B SAP Adapter
Version SP5 Fix12
Build Number 643
JayCo Version 2.1.8 (2006-12-11)
JayCo Middleware sapjcorfc
JayCo Middleware Version 2.1.8 (2006-12-11)
jRFC Library Version 2.1.8 (2006-12-11)

While parsing the IDOC (ORDERS) using the builtin ‘transformFlatToHierarchy’ service for conveting the control,data records to IDOC structure we are facing a problem with the root tag. The root tag of the output (in bound node) for the ‘transformFlatToHierarchy’ service has ZORDER05(CIM Type) instead of ORDER05(IDOC Type).

But when we tried in the system with non unicode SAP Adapter 4.6 without SP5 Fix, the root tag was as expected(ORDER05)for the same input.

We tried both the ‘transformFlatToHierarchy’ services in SAP package[inside pub(new)and outside(old)] to receive the same results in both the system. We even tried the ‘conformsTo’ input by giving the path of expected IDOC, but with no success.

1. Could anyone please tell us why this problem with root tag occurs?
2. Is it due to the unicode settings or fix SP5?
3. Could anyone please let us know how the service ‘transformFlatToHierarchy’ parses the records(control and data) to the desired IDOC. where&How does it fetch the schema of the IDOC?
-----------------------------------------------------------------------

Also adding to the unicode problem,

While testing the SAP connection, we see the codepages used are different.like:
ownCodepage 4103
partnerCodepage 4102

Does this have an effect on the previous problem.

Please provide your valuable comments\opinions…
:frowning:

Thanks in advance for your efforts,
JK

I would say you also upgrade the SAPAdapter4.6 to 6.5 and that should support ECC5.x/6.x systems with out issues and it makes your IS6.5 environment in sync…Also i am aware that SAPAdapter4.6 with SP5 does support ECC versions.

Also check this SR article:

https://advantage.webmethods.com/advantage?targChanId=kb_home&oid=1613453255

HTH,
RMg


Hi RMG,

Thanks for your inputs. As described in the SR link, we have checked our systems.

  • We are using 2.1.8 JCO libs.
  • The assigned SAP repository is a Unicode SAP system
  • The program ID on the corresponding listener SAP system have setup for unicode communication.

We would like to know whether the SP5 fix will affect\alter the working of ‘transformFlatToHierarchy’ service in the SAP package? This service creates the IDOC structure with content of ‘CIMTYPE’ filed(ZORDER05) in EDIDC40, instead of ‘IDOCTYPE’ field(ORDER05) in EDIDC40.

Could you please let me know, from where this service gets the IDOC schema\structure metadata ?

Is it because of the use of UNICODE?

Thanks in advance,
JK

Hi All,

We have finally resolved the problem. It was due to the SP5 fix. this will automatically use CIMTYPE instead of IDOCTYPE.

To correct it we need to add and set the property “watt.sap.ignoreCIMTYP” to “true”.

This is mentioned in the readme.txt file of the SP5 fix.

@RMG,
Once again thanks for your suggestions.

b4n
Thanks,
JK

Great…thanks for the update!!