hello,everyone.this question is about xQuery.


Not a valid request

The request has been rejected due to invalid or missing parameters.

Check the request parameters using supplementary error diagnostics in other messages

replace input()/GWLZ[/WenDangID=‘905’]/FuZeRenID
with (90)

tamino version:
the update sentence will take the INOXME8552 error
I don’t know how to use it.

I want to learn more form here!

Hello kreven,

my first idea was that things were getting confused by the parentheses in the “with” part of the replace statement.
However, when I tried this on my Tamino the update worked.

I tested with this:

   replace input()/Employee[Id='gurayou']/Phone
      with (<Phone>90</Phone>)

I’m not sure exactly what update expression you are using, because the Forum has converted some of the characters into a Smiley Face - :wink: !

The biggest difference that I can see is that I have hotfix 9 installed. I strongly recommend that you contact your local Software AG Customer Support Center and get this hotfix too.

If that still doesn’t help, please let us know! In the Forum’s “Post A Reply” window there are a few buttons. One of them has the characters </> on - this will add “code tags” to the post. Please put your query inside the code tags to prevent the Smiley Face “problem”. :slight_smile:

I hope that helps!