Getting an error when trying to run web service connector created with WSDL with SOAPMSG protocol

Hi,

I generated a WSDL for a service with SOAP-MSG protocol. My service has one input and one output documents. After that I created new web service connector for the above WSDL. When I run the web service connector I am getting the following error.

SOAP-FAULT
faultString: [ISS.0088.9122] Service com..us.ins.product..dpa.websvc:updateUDBRequest does not exist

The reason im using SOAP-MSG to program special behaviors encoding/decode the data and processing SOAP Headers.

I have gone through the ISSoapProgrammingGuide.pfd didnt help much.

I stuck and unable to go further, any help in this regard is appreciated.

Thanks in advance
Leon

Leon,
Doesn’t sound like it is finding your service. Is your namespace setup correct?

See this link for more help. http://www.wmusers.com/wmusers/messages/117/49333.shtml .

markg
http://darth.homelinux.net

Leon,

That error usually means that the IS default soap processor can not find a service with Universal Name settings that match the local name and namespace definition of the message you are sending.

For example, if the soap body contains an element called “ns1:myService” with xmlns:ns1 defined as “urn://mynamespace” the UniversalName settings must have a Local name of “myService” and a Namespace name of “urn://mynamespace”.

If these don’t match exactly, then the default soap processor can’t determine which service to invoke and throws the exception you are getting.

Mark

Hey Mark … Got that part running, I wasnt giving the right namespace in my XML schema.

Thanks for your response.
-L

“I love it when a plan comes together.” - Col. Hannibal Smith - The A Team

Hi Mark,

I was getting an access denied error earlier which was fixed it was just an ACL issue but now im facing 2 exceptions. Can u pls look into it and help me with your valuable advice.
Heres the exception:

<?xml>
<soap-env:envelope>
<soap-env:body>
<soap-env:fault>
<faultcode>SOAP-ENV:Client</faultcode>
<faultstring>[ISS.0088.9134] Exception occurred while processing the body of the message</faultstring>
<faultactor> http://*******01:7777/soap/default</faultactor>
<detail>
<webm:exception>
<webm:classname>com.wm.app.b2b.server.ServiceException</webm:classname>
<webm:message>java.lang.Exception : missing required parameter ‘document’</webm:message>
</webm:exception>
</detail>
</soap-env:fault>
</soap-env:body>
</soap-env:envelope>

Any help in this regard is appreciated,
Thanks
-L

Usually this means that you have an error when extracting a document from the body of the soap message.

  1. Use pub.soap.utils:getBodyEntry to get a node, []Use pub.xml:queryXMLNode to extract an object representation of the document you are looking for. Be sure to set the nsdecls parameter to the correct namespace (prefix doesn’t matter) so that you will be able to extract the payload no matter what prefix is used. []Convert the extracted node to a document using pub.xml:xmlNodeToDocument

Mark