GC overhead limit exceeded and Heap space error while starting Integration server

Hi,

I’m facing an issue while starting the Integration server. I get heap space error
below is the configuration of my system

java.lang.OutOfMemoryError: GC overhead limit exceeded
java.lang.OutOfMemoryError: Java heap space

OS : Windows 7 (32 Bit)
RAM : 4GB

I’m using the below config in setenv
set JAVA_MIN_MEM=512M
set JAVA_MAX_MEM=512M
set JAVA_MAX_PERM_SIZE=256M

measures followed, cleared all the packages from IntegrationServer/packages folder. Cleared the packages from replicate (inbound, outbound, salvage and archive)

I’m unable to sense why i’m still getting the error.

I also tried changing the Java Runtime parameters size to -Xms1024m. (under Control Panel->Java-> View). I didn’t help.

Please let me know what might be the possible cause for this issue.

Many thanks,
Monish

JAVA_MIN_MEM is the minimum heap size.
JAVA_MAX_MEM is the maximum heap size.

Could you try to set this as 256MB and 1024MB and try again. Basically we are trying to increase the memory where is the server processing the transactions.

hey lance,

I tried with the below setting now

set JAVA_MIN_MEM=256M
set JAVA_MAX_MEM=1024M
set JAVA_MAX_PERM_SIZE=256M

I got the message while starting as “could not reserve enough space for java heap”

attached is the screen shot

Capture.PNG

Get the IS down and make changes to server.sh/bat file and restart the IS.

If you still face issues reduce teh MAX_PERM_SIZE to 128M following the above steps.

BTW what is your wM version?

i have changed the following settings in the following file. check out if it works.

Initial Java Heap Size (in MB)

wrapper.java.initmemory=1024

Maximum Java Heap Size (in MB)

wrapper.java.maxmemory=2048

C:\SoftwareAG\profiles\IS_default\configuration\wrapper.conf