FTP problems on Flow Service


I have problems with a Flow Service on webMethods 8.2

What I pretend to do is taking a file from a remote server by ftp. But, when this file becomes bigger and I run this service again I want to take just the piece of file what have change.

First I use the service client.ftp:login for begin the communication, I navigate to the folder where the file is in the remote server. Then I start using RAW commands, and for that I use client.ftp:quote, first I check if the size of the file (the string I use in the quote is size ‘filename’) for evaluate have changed. If that happens, I establish a binary communication (the string is TYPE I) and the passive mode (PASV). The next step is marking where I have to start reading the file, and for that I used the RAW command, with quote, REST ‘position’ at this point everything works right, but now I have the problem with the RAW command RETR, with the quote I indicate the following string rest ‘filename’ and when this operation is done the program keeps running but not finishing.

I have tried using client.ftp:get but it doesn’t work with a piece of file, just for the entire file, I also have tried with ASCII transfer and it isn’t allowed for the FTP, and it doesn’t work.

This is the FLOW SERVICE if it could help.



FTP principles dont directly support a piece of information that needs to be fetched. It works on complete files. So this is not directly possible.

Thank you Sam…

We finally solved it by taking away the ‘ftp:quote’ where we set the transfer as binary [ftp:quote (BINARY…)] and replacing the ‘ftp:quote’ where we get the file [ftp:quote (RETR…)] for the service in the WmPublic package ‘pub.client.ftp:get’ and, in the Service in parameters, we set the transfer mode (transfermode parameter) as binary and it works bringing us just the piece of the file we want to take instead of the entire file.

Best Regards.

Hi Marcelo. Thanks for the information. We can use this across other discussions as well.

Hi Marcelo,
I am also trying to make the same service but when I am using pub.client.ftp:get after ftp:quote[REST], I am getting the full file,instead of getting a parts of the file which is passed as pointer value in REST command…

Also i am not sure about the argument to be passed in REST command in ftp:quote.I have only passed the pointer value from where file reading to be started.