Filling a Record List with multiple SQL Query Results

I guess my question is very basic, but I tried to fill a Record List with many SQL queries using the execSQL service.

I would like to be able to put the result of each of my queries on a separate line within my record list. The result of each of my queries is always one record

I tried tho use AppendToRecordList but that don’t seems to work.

Thank

Yan

Yan, can you please provide some additional information?

  1. What is your SQL query statement?
  2. What is your RecordList structure?
  3. What is your result set that is not properly mapping to your RecordList?

Thanks.

Hi Yan,

Create a RecordList and have record inside it.Now map your “results” variable out of execSQL to the inner Record of RecordList.This will solve ur problem.Further queries feel free to mail me.

Rgds,
Prabhu.

Hi , thanks you for your quick answer

Let me explain my problem to a simpliest way.

I have a variable into pipeline in (string) and I simply want to map this variable to a RecordList into pipeline out.

Theses 2 variables are into a loop, so every time I loop I want to map the variable to my RecordList. Actually my mapping always write over the first line of my array. What I really want is to write to Line 0 then line 1 then line 2 until my loop finished.

Here’s the final result I expect to get

MyRecortList
MyRecordList[0]
ValueA
MyRecordList[1]
ValueB
MyRecordList[2]
ValueC

Each value come from the same variable but the value change a every loop

Thanks again

Yan

Do a loop on the results from the SQL Query and in the out-array specify the recordList that you want to create.
Thanks
VR

It appears that I am running into the same issue as Yan is. I am looping through the results of an SQL Query but my output doesn’t map properly. Ultimately what I would like is a straight mapping from results to a record list. I just haven’t been able to get the out-array index to increment. Does anyone know a special trick to get this to increment with the in-array

Hi, Tim.

You may want to check out http://www.wmusers.com/wmusers/messages/117/366.shtml for more information on RecordLists and mapping them.

The behavior you are seeing indicates that the RecordList contains a reference to the source Record and not the actual data fields. In the above URL, there is a discussion about creating a temporary Record structure for mapping from one RecordList and into another.

Don’t worry – you are doing everything properly. There just are some “gotchas” associated with this process because of the variable referencing that goes on.