Field Naming Standards

Does anyone have any thoughts about naming standards for fields and variables used in the Application Designer?

I have been using my own system, but do not know if this is adequate.


Hi Demos,

here are some rules we use for our example programs:

    We are adding a “status” or “visible” to the property name. Examples: “nameStatus”, “nameVisible”

For NATPAGES we often use property names like “”. This means we are “collecting” the single statusprops. Then we can use the Natural RESET to reset all status values with one line of code.

  1. For VALUEPROP/GRIDPROP… we are usually using the business names. Examples: firstName, lastName…

  2. For PAGE layouts we use the Java naming conventions (start with lower case…). For NATPAGE layouts Natural naming conventions are more familiar in the Natural code. But: the naming conventions for layout properties are stricter than Natural naming conventions. It must be a valid XML name. You only can get around this by setting an additional njx:natname value.

To summarize what we are doing:
It helps if the naming shows wether it is business or other data (status,…) + Use the familiar language naming rule (Java, Natural) as far as possible.

Best Regards,