Exception occured while creating web service connector

Hi,
I got the WSDL file from my partner and try importing it in webmethods developer 6.1. It throws exception while generating web service connector. I opened the WSDL file in XML spy and it validates it and proves it as well formed. It throws the following exception while generating web service connector :

WSDL code: S-9043
[ISS.0092.9043] Schema Error: 1
pathName: null

        errorCode: XSDC-003 

        errorMessage: [ISC.0082.9705] Definition not found 

Any idea about this error ?

  • nilesh

Hmmmm. Does the WSDL refer to an imported schema? Is that schema available on your machine in the same folder as the WSDL file?

Mark

Mark,
Yes. The schema is available in the same folder as the WSDL File.
I have validated that schema and WSDL files, both in XML sply.

I have no idea how and where webmethods locates the schema while importing the WSDL file ?

  • Regards,
    Nilesh

Mark,
One more thing I want to ask that I have read the WSDL tutorial and some article on the net, it says the following tag must be available in the WSDL file with some value.
“<wsdlsoap:operation/>”

I have it as empty tag. no value. whether it is creating any problems ?

  • nilesh

Nilesh,

Can you post the WSDL file as an attachment?

Mark

Mark,

Here you go !!

Note: To keep the privacy of the client data, i have replaced word “abc” wherever it specifies my client’s name.

  • nilesh

WSDL File
DataService.wsdl (2.4 k)

Nilesh,

Generally this tag “<wsdlsoap:operation/>” in the WSDL file is used for creating documentTypes(with field params that will be passed in the webservice invoke when Request/Response and these will get created when you create webServiceConnector in the Developer.

HTH,
RMG.

Can you post the Messages.xsd file as well? Have you tried editing the WSDL to replace the import with the contents of Messages.xsd?

-mdc

RMG,

Thanks for clearing my doubt.

Mark,

Sure. I can post the Messages.xsd. I didnt get how to replace the import with the contents of schema ? Can you throw some more light on this. Here is the Messages.xsd attached.

  • nilesh

Messages.xsd
Messages.xsd (1.7 k)

OK, now post "abcDatatypes.xsd and “DatsupplDataema.xsd”. I’m thinking that IS couldn’t chase through the multiple levels of imported schemas but that’s just a theory at this point.

-mdc

Mark,
Sure I will post those documents also. But I m home in weekend and dont have those files with me. Monday I will be posting the files.

Thanks for your prompt help.

  • nilesh

Mark,

Here are the requested files attached. If you need anything else, let me know.

Regards,
Nilesh

DataSchema.xsd
DataSchema.xsd (6.8 k)

abcDatatypes.xsd
abcDatatypes.xsd (14.2 k)

Mark,
I got new WSDL file and schema from my partner. It includes two XML schema and one WSDL file.

I tried to import first schema in developer, it went through. when I tried to import WSDL and/or second schema, it is throwing following error. I couldnt find this error code anywhere in webmethods docs.


[ITD.0013.0001] Server connection to ‘localhost:5555’ lost: Reason unknown. Try restoring session later to save changes.

But the server is up and running …that’s what i confirmed.

And it pops up with this message and only ‘OK’ button. So I couldnt get more detail about this error.

Any Idea about this error ? I dont know where is the problem ? In WSDL, or in Schema or in my developer. Now I got fed up with this. I am not able to import a WSDL file since last few days.

if someone can help me regarding this , i would appreciate.

thanks in advance …

  • nilesh

Drop me an email at mcarlson {AT} conneva.com for some offline comments.

Mark

Hi Friends,

Now there is a change in the WSDL file from the client. with the new WSDL file importing in webmethods, i am getting the following error:

com.wm.lang.xml.WMDocumentException: [ISC.0042.9322] External ID is missing the system ID

I tried searching for this error code in webMethods documentation, there is no error like this. I tried even on wmsusers.com, but threads having this error code.

You guys have any idea what is the error about ?

Thanks in advance …

Regards,
nilesh

Hi Mark,

I’m facing the same problem with my disconnects. Can you please let me know any solution ? Whats causing it ? Even if i dont run any service, it just happen to be on a random basis.

[ITD.0013.0001] Server connection to ‘localhost:5555’ lost: Reason unknown. Try restoring session later to save changes.

Thanks & Regards,

-Leon

Leon,

The error means Developer can no longer connect to the IS on your local machine. Does IS shutdown and, if so, what error messages are shown?

Mark

Mark,

Heres the error message i get.

[ITD.0013.0001] Server connection to ‘localhost:7777’ lost: Reason unknown. Try restoring session later to save changes.

Session to ‘xxxwmd01:7777’ has been restored.

The IS doesn’t shutdown but refreshes.

Heres the error message:

java.net.ConnectException: Connection timed out: connect

at java.net.PlainSocketImpl.socketConnect(Native Method)

at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:305)

at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:171)

at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:158)

at java.net.Socket.connect(Socket.java:452)

at java.net.Socket.connect(Socket.java:402)

at java.net.Socket.<init>(Socket.java:309)

at java.net.Socket.<init>(Socket.java:124)

at com.wm.net.NetURLConnection.httpConnect(NetURLConnection.java:563)

at com.wm.net.NetURLConnection.connect(NetURLConnection.java:162)

at com.wm.net.HttpURLConnection.getOutputStream(HttpURLConnection.java:421)

at com.wm.net.HttpURLConnection.getOutputStream(HttpURLConnection.java:401)

at com.wm.driver.comm.b2b.http.SessionHTTPLink.transportMsg(SessionHTTPLink.java:90)

at com.wm.driver.comm.b2b.http.HTTPLink$HTTPSendReceive.run(HTTPLink.java:453)

at java.lang.Thread.run(Thread.java:534)

Thanks,
Leon

Is Developer on the same box as the Integration Server? Is this error happening when you are executing a web services connector or when you are using Developer to generate a WSD from a WSDL?

Mark