Error with WmTnWeb

Hi Chirag,

Please login as Administrator or TNAdministrator to WmTNWeb. Then go Configuration → Configure Web Manager for partners options. Set the values as you desired for your partners and save. Then try login as a partner and check if the page is properly displayed.

  • Rajesh Rao

Hi Rajesh,
The error is coming when i log in as the Administrator.

even as Administrator, i can not view the page of TNWeb.

It seems to me, that the internal storage which can be accessed by pub.storage services is corrupted. How do I recover it?

Hi Chirag,

Certainly looks like the repository is corrupted. Did you try restarting the server. If you have done that try this first.

If this does not work, try copying all the files from the repository directory to another backup directory. Delete all the files and try starting the server again.

  • Rajesh Rao

Whenever the file-based repository gets corrupted you have to shut down IS, delete all the files from WmRepository2 but before you reboot set the following property in the %wm_install_dir%\WmTN\config\properties file: tn.webmgr.60config=false. This will tell IS to not look for permissions in the repository when it boots up.

TN stores your permission configuration for TNWeb in the repository so when it gets corrupted or deleted you lose this info.

It is true that the TNWeb stuff is stored in the repository. Why it is missing from yours is not known. It may be that the repo is corrupted. Or maybe not.
Before doing anything dramatic to your repo please try this:
In <is>\packages\WmTN\config\properties.cnf there is a line like: watt.<something>.<something.something=false (I am not at work so can not look up the exact parameter - maybe someone else can give the exact line.) I do remember that it contains a string that clearly has to do with TNWeb. If this line is set to true or deleted WmTNWeb will reinitialize the repo. I have to do this quite a few times.

I dd not read all of the posts before I added my two cents. The property Will mentions is the property that will cause the repo entries to be rebuilt. Either set tn.webmgr.60config=true or delete the line. When I have done this I have not needed to delete anything in the repo. Just restart IS, although it is possible that simply reloading WmTN will do the trick.

Is there any easy way of doing this without screwing up the permissions for the 60 partners that I have already setup for WmTNWeb?

If I change the tn.webmgr.60config=true value, will I lose all the specific permissions for all partners? I don’t want to have 60 angry partners calling me with access issues.

Somebody please help.

Michael