Error while creating a new asset type in centrasite 8.0 SP4

I tried to create a customised asset type “ABC” in centrasite, after provding the details when i save, i get the below error:

INOQJE0032: Error executing the request with error [7126 , INOSXE7126 , Server extension failed , INOSXE7114: Java error: Errtext: ‘javax.xml.registry.JAXRException: com.softwareag.centrasite.policy.PolicyException: com.softwareag.centrasite.policy.PolicyException: java.lang.SecurityException: Server redirected too many times (20)’. Stacktrace: 'com.centrasite.jaxr.LifeCycleManagerImpl.saveObjectsInternal(,
+++com.softwareag.centrasite.policy.PolicyException: com.softwareag.centrasite.policy.PolicyException: java.lang.SecurityException: Server redirected too many times (20),,

Why does this error occur ?

I have previously tried to create new asset types and they were successfully saved

Anusha Srinivasan

Hi Anusha,

Looking at the error message, i presume you might have Policies set on creation of assets.
Please have a look at that area. If nothing is set related to it, then can you share what other details you are providing to the custom asset type.


Hi ,
We are just provding the Name and description for the custom asset, also we have not explicitly created any policies for asset creation.

Attached are the screen shots of policies avaialble.

Anusha S
policies.bmp (1.22 MB)

which Hotfix do you have installed?


Am unable to find the Hotfix details, May i know where to look for this information?

Below are the details of centrasite version installed


  Application Server Tier 8.0 SP4

  Application Server Tier Extension 8.0 SP4

  Registry Repository 8.0 SP4

  Registry Repository Extension 8.0 SP4

  Shared Files 8.0 SP4

  Shared Files Extension 8.0 SP4


  Web Services Stack

      Core Files 8.0 SP5

      Administration 8.0 SP5

      Web Application Files 8.0 SP5

      Web Application Deployment 8.0 SP5

  Java Development Kit 1.6

  Tomcat Kit 8.0 SP3

  System Management Hub 8.1 SP2

Anusha S

please go to our Empower Site ( and locate the fixes there under Knowledge Center > Product Fixes.


Hi Daniel,

In the product fixes–>fix exlporer–>product(w/fixtype) when i type centrasite and search i do not find any results :frowning:
and there is a message saying “Valid Support Contract required for Access”
Same is the case with Fix set also .

Do we need any special access to use this knowledge centre?
If so how to we get it.

Anusha S

Empower is restricted to customers with maintainance contracts. You might have to check who in your company has the support contract details and the empower credentials.

Hi Daniel,

We just restarted the TOMCAT server and stopped and started the resitry/repository and it worked out.

We are now able to create new assets, Also we found that there is a policy exception with event type precreate from policy logs.

Thanks for the help.
Anusha S