error while batch inserting data

I am trying to execute a batch insert adapter service and I get the below error,

[ART.117.4002] Adapter Runtime (Adapter Service): Unable to invoke adapter service JDBCConnections:
[ADA.1.316] Cannot execute the SQL statement “INSERT INTO (,,) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)”. "
0(0)
B [SQL0803] Duplicate key value specified. Cause . . . . . : An INSERT, UPDATE or ALTER TABLE statement was issued. Unique index or unique constraint

_PK in exists over one or more columns of table
in . The operation cannot be performed because one or more values would have produced a duplicate key in the unique index or constraint. [/b]

Please advise if this an issue on the database side or should I be making a change to the adapter service.

Thanks in advance!

Please do check the value that you are trying to insert is trying to replace with the private key value…

Its definitely a data error, database is not accepting one of the field value which is unique and not altered

Thank you Sreekanth! I got it solved.

I had the same error , then i check the data and found the same reason ,thank you very much !