Error when calling webservice from Net client

Client is calling webservice from .Net and getting the following error
“The HTML document does not contain Web service discovery information.”
I have used Soap-rpc protocol (Is 6.0.1 with SP2) and gave the url to client . He is not able to invoke the webservice from his end but Wsdl file is generated when he tried from browser.
Any clue where the problem is

You guys are using custom processor or default soap processor to invoke Integration Server service?.

we are using default soap processor

This is a config issue at MS side,
The following link can help you.
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q307303
a) Make sure to use the correct file extension. Use either “.asmx” or “.vsdisco”

b) Try using a direct URL to the “.asmx” file.
e.g http://localhost/WebService1/WebService1.vsdisco

c) If you are using the “.vsdisco” file extension and you still get the error message, then make sure to enable (uncomment) the “DiscoverRequestHandler” in the machine.config file.

d) If you are using the “.vsdisco” file extension and the “DiscoverRequestHander” is enabled, but you get an “Access is denied” error message, then add your username to the machine’s local “VS Developers” group.

He has done these. He is also working with some other web services developed in other technologies other than webMethods but he is getting problem with our url only

Since you are using default processor, i can think of the following problem.
You need to use access controlled SOAP processor, When .Net sends a initial SOAP request it does not send the user name, pwd.They send only when they recieve a 401 staus code.wM default SOAP processor permits anonymous access and because of this these client will not receive status code 401.ISSoapguide can help you in configuring a access controlled SOAP processor.

~Prabhu