Error in Trading Network

Hey guys,

Do you have any idea about this error when I startup WM?

Exception while initializing the LockManager com.wm.app.repo.RepositoryException: com.wm.util.queue.ValuesHashException: [B2BCORE.0066.9104] DirValuesHash corrupted, missing file VH131025627408189 for key TNQueryResults_ac141da5f70dc28400001c67

2002-11-11 12:25:52 [B2BSERV.0028.0012] WmRoot: Startup service (wm.server.ns:
syncToNamespace)
2002-11-11 12:25:52 [B2BSERV.0028.0013] Startup service exited with the follow
ing error: java.lang.NullPointerException
at java.lang.Thread.run(Thread.java:484)
2002-11-11 12:25:54 [B2BSERV.0028.0013] Startup service exited with the follow
ing error: [B2BCORE.0063.9107] [TxMgr] Service Disabled
2002-11-11 12:26:30 [B2BSERV.0028.0014] Startup service wm.ejb.MyIM:startup wa
s not found in WmEJB package

2002-11-11 12:26:29 [B2BSERV.0028.0012] WmTNWeb: Startup service (wm.tnweb.hel
per:startup)
2002-11-11 12:26:30 [B2BSERV.0028.0013] Startup service exited with the follow
ing error: java.lang.Exception: com.wm.app.repo.RepositoryException: com.wm.util
.queue.ValuesHashException: [B2BCORE.0066.9104] DirValuesHash corrupted, missing
file VH131025627408189 for key TNQueryResults_ac141da5f70dc28400001c67
2002-11-11 12:26:30 [B2BSERV.0028.0012] WmDB: Startup service (wm.server.db:st
artup)

Sounds like another corrupted repository. Webmethods is looking for a file in the WmRepository2 directory under your webmethods tree. If this file is gone for some reason, I would wipe out the entire directory and reboot. You will lose some stored data (ejb alias info, user locks, unfinished transactions, etc).

As a group we should probably contact webMethods about improving their documentation about the repository (or better yet removing it!) that comes ‘out of the box’.

Will

There is a fix for the repository. WmTnFix(put number here).

Not sure if it is applicable for this or not, but it helped us. Check advantage for the specifics.

Ray

Will/Ray …Thanks for your help.

Ray, do I need to apply some Fix? where can I get that file?

Thanks

Hey thanks…I remove the WmRepository2 directory and restart the server. It fixed also my problem in EJB Adapter.

Glad it worked for you. There are some side effects (lost user locks, ejb alias info, transactions, etc) but it sometimes has to be done. One other effect I noticed recently is if you use the TNWebManager to submit docs to TN - if you’ve set up any security restrictions, webmethods stores this info in the repository - once it’s blown away you will get a stack trace error on the screen (not good). Let me know if you come across this

Will Kriski

Hi Will,

I was reading your message from November…we have
encountered the second effect you mention, losing the access
to TNWebManager after deleting wmRespository2. Do you know
how we can fix this?

thanks,
Anne

Assuming you’re using 4.6, look in the packages/WmTN/config
directory and open up the properties.cnf file. There’s a
property in there, something like webmgr.config=true.
(can’t quite remember the property). Set this to false - it
seems webmethods expects some info to be in the repository.
By setting this to false it will re-initialize itself.

Will Kriski

All,

I just wanted to thank each one of you for sharing the wmRepository information. My directory got corrupted and we had a pending implementation to be completed. I just read all your experiences and followed the instructions. It worked fine.
I am thankful such a forum existed.

God bless you all.

Reji

I have to agree with Regi. Thank you for sharing your experiences. We were getting ready to re-install everything if didn’t find this here. Good thing it was only the test environment. Thanks again.

Wow, We got the same error and this thread really helps my problem get solved.

Excellent contribution. I am really thankful to you all.

everybody who is trying to post some new threads, please search for the forum, it will help you find some really good answers.

Once again, thanks a lot to all.

Hi guys,

could any body give me guidence where can we get fixs and jar files for that fixs. How can we rectify those problems raised for fixs. Thanks in advance

karuna

Having the same problem, I tried wkriski’s suggestion of setting the property to false and it worked. Issue fixed. :slight_smile:


Protocol Myim