Edit Skin

Hi,
I have a Skin created with MWS 7.1.1. Now we have upgraded to 7.1.3 and I want to modify this skin.

I go as sysadmin to Folders > System > Skins > ABCSkin and select the tab [Colors].
I change the colors for some components and click the Save button, but the changes to the skin are not saved (the old values are kept).
I have also tried to export/import the skin and just edit the /css/base.css file but the skin is not updated.

Have you encountered this problem?

br,
Vlad

hi
do you see any error in the MWS logs after you edit your skin (in the skin editor) and save it?

Changes in the css files will be overwritten the next time you use the skin editor. You could use “csi” files (have a look into the pearls skin for details) to let these changes be generated. The usual way is to create an “extended.csi” file (this has to be included in the skin.properties.xml file; in the pearls folder you’ll see how this looks like). An “extended.css” file will be generated out of it.

hope this helps,
Javier

Hi vlad and Javier,

I have problem importing skins in MWS.
Exported a Testingskin. It have created a TestingSkin.skin ( file type is gZ) in my local folder.
I have modified extended.css ,zipped the file back with name Testing.skin. When I import it back to MWS , I see the error " System cannot support the file type [ZIP]. Supported types are pdp. skin, …"
When I try to import it back to MWS, even with out any changes, I see the same error.

Please let me know , if you have any information about the issue.

Thanks

Try unpacking the contents (it sounds like they are gzipped) into a folder. Then use a zip utility to zip them up (no compression needed) and rename to .skin.

Thank you for the information.

I am able to import the skin, when modified the file type to .skin.
I am able to import the same skin back, without any change.
I actually want to add a .css stylesheet to the skin. When I modify the .css and add an entry to skin.Properties.xml and upload it back, I get a null pinter exception " skindeployxml" not found.

http://tech.forums.softwareag.com/techjforum/posts/list/24096.page

I have tried clear everything in the server/default/temp folder and restart MWS ( as indicated in other thread). But the issue remains.
Please help.

Thanks.