Edit profile not working

When I click the “Edit Profile” button to update my display name and GMT offset, it allow me to make and submit the change. But then nothing actually gets updated.

Can you please fix this defect?

Just tried if I can update my account details and it worked fine,
so it must be something in your environment.

What browser are you using ?
Are you using any script blockers or the like ?

Thanks for helping out!

I have tried with both Firefox 6.0.2 and IE 7.0.

I have not installed any script blockers. My IT department has pre-installed all kinds of security software, but this hasn’t caused any problems with any other web sites.

I tried it again today (both from home and from the office), and in both cases I am now getting the following error.


Thank you for reporting this. We are currently checking it and we will follow up with you shortly

Best regards,


Can you please try editing your profile now and let us know if you are still not able to.

Best regards,


seems to work at my side…

I don’t know what you guys changed, but now it works for me! yeah! Thank you. :smiley:

I didn’t do anything different. It just started working.