DT-100 Unable to Locate Type Definiton

Hi folks ,

While publishing a document i am facing the following issue

Data does not conform to the Publishable Document Type
pathName=/tns:AgreementEventProcessRequest/tns:RequestID errorCode=DT-100 errorMessage=Unable to locate type definition

According to the schema we imported RequestID is defined as Guiid we are maping the same thing to it but still facing the issue same thing it worked in other machine

using WM 9.5

If any one faced this issue please let me know



The problem might be with the Document, please check if that document has references to certain types defined in an obsolete namespace: Fixing the broken references will help to resolve the DT-100 error and the document will get published successfully.

Also try regenerating the document type using XSD in a new package. Before publishing sync the document to broker.

Let me know your results.

I had the same problem, and when I check all the references were right, so what i did and it work for me, was to turn off input validation on the service where i was using the document, save and run the service, then i turn on input validation again and magically it worked as usual.