Does Tamino support Word 2003?

cHello!

My software is:
- Windows 2000 Professional + SP3
- Tamino 4.1.4
- Tamino Schema Editor 4.1.4.3
- Internet Explorer 6.0 & Mozilla 1.5
- Microsoft Office 2003
- Microsoft Office 2003 XML Reference Schemas

There are eight XSD format schemas in “Microsoft Office 2003 XML Reference Schemas”:


  • aml.xsd
  • office.xsd
  • vml.xsd
  • w10.xsd
  • wordnet.xsd
  • wordnetaux.xsd
  • xml.xsd
  • xsdlib.xsd


Using “Tamino Schema 4.1.4.3”, I just converted these schemas in TSD4 format and loaded them into “office2003” database Tamino, in the same collection “word2003”. After this, I created very simple document in “Word 2003”, saved it as a XML document, and using “Tamino Interactive Interface” loaded it successfully into Tamino. I got the following information messages:

--------
ino:response
<ino:message ino:returnvalue=“0”>
ino:messagelinedocument processing started</ino:messageline>
</ino:message>
<ino:object ino:collection=“word2003” ino:doctype=“wordDocument” ino:id=“1”/>
<ino:message ino:returnvalue=“0”>
ino:messagelinedocument processing ended</ino:messageline>
</ino:message>
</ino:response>
-------

Now, I executed the following query:

1)
http://localhost/tamino/office2003/word2003?_xql=w:wordDocument

Unfortunately, it returned the following message: :frowning:

------
<?xml version="1.0" encoding="ISO-8859-1" ?>
<ino:response xmlns:ino=“http://namespaces.softwareag.com/tamino/response2” xmlns:xql=“http://metalab.unc.edu/xql/”>
xql:queryw:wordDocument</xql:query>
<ino:message ino:returnvalue=“0”>
ino:messagelineXQL Request processed, no object returned</ino:messageline>
</ino:message>
</ino:response>
------

After, I tried using this query:

2)
http://localhost/tamino/office2003/word2003?_xql=count(w:wordDocument)

… but I got the following messages:
------
<?xml version="1.0" encoding="ISO-8859-1" ?>
<ino:response xmlns:ino=“http://namespaces.softwareag.com/tamino/response2” xmlns:xql=“http://metalab.unc.edu/xql/”>
xql:querycount(w:wordDocument)</xql:query>
<ino:message ino:returnvalue=“0”>
ino:messagelineXQL Request processing</ino:messageline>
</ino:message>
xql:result0</xql:result>
<ino:message ino:returnvalue=“0”>
ino:messagelineXQL Request processed</ino:messageline>
</ino:message>
</ino:response>
------
Unfortunately, it returned zero records. :frowning:

I also executed the following query:

3)
http://localhost/tamino/office2003/word2003?_xql=count()

and I got messages:

-----
<?xml version="1.0" encoding="ISO-8859-1" ?>
<ino:response xmlns:ino=“http://namespaces.softwareag.com/tamino/response2” xmlns:xql=“http://metalab.unc.edu/xql/”>
xql:querycount(
)</xql:query>
<ino:message ino:returnvalue=“0”>
ino:messagelineXQL Request processing</ino:messageline>
</ino:message>
xql:result1</xql:result>
<ino:message ino:returnvalue=“0”>
ino:messagelineXQL Request processed</ino:messageline>
</ino:message>
</ino:response>
-----
So, this query works pretty good! :slight_smile:


After executing these queries, I executed the following queries:

4)
http://localhost/tamino/office2003/word2003?_xql= (OK)

5)
http://localhost/tamino/office2003/word2003?_xql=
[w:body/wx:sect/w:p/w:r/w:t=‘Tamino’] (not working, returned zero)

6)
http://localhost/tamino/office2003/word2003?_xql=w:wordDocument[w:body/wx:sect/w:p/w:r/w:t=“Tamino”] (not working, returned zero records)

7)
http://localhost/tamino/office2003/word2003?_xql=[o:DocumentProperties/o:Pages=1] (OK)

8)
http://localhost/tamino/office2003/word2003?_xql=w:wordDocument[o:DocumentProperties/o:Pages=1] (not working, returned zero records)

9)
<A HREF="http://localhost/tamino/office2003/word2003?_xql=
[@ino:id=“1”]" TARGET=_blank>http://localhost/tamino/office2003/word2003?_xql=[@ino:id=“1”][/B] (OK)

10)

<A HREF=“http://localhost/tamino/office2003/word2003?xql=w:worddocument[@ino:id=“1”]
” TARGET=_blank>http://localhost/tamino/office2003/word2003?_xql=w:wordDocument[@ino:id=“1”][/B] (not working, returned zero records)

There are my questions:

1. Why Tamino didn’t recognize “w:wordDocument” doctype although it had loaded XML data successfully in database “office2003”?

2. Why didn’t return data the following query?
http://localhost/tamino/office2003/word2003?_xql=
[w:body/wx:sect/w:p/w:r/w:t=“Tamino”]

3. Why query with asterisk “*” [see 4th query] works very good, but query with doctype “w:wordDocument” doesn’t work [see 1st query]?

4. What should I do to make it work? Please help.

Any clues, suggestions, tips will be very appreciated!

In advance, thanks a lot!

best regards,
Dariusz Baumann

PS.

Info:
1. Database - office2003
2. Collection - word2003
3. Doctype - w:wordDocument

This is my XML document (created by Word 2003) which I loaded into Tamino:

-----------------------------------
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<?mso-application progid="Word.Document"?>

<w:wordDocument xmlns:w=“http://schemas.microsoft.com/office/word/2003/wordml

xmlns:v=“urn:schemas-microsoft-com:vml” xmlns:w10=“urn:schemas-microsoft-com:office:word”

xmlns:sl=“http://schemas.microsoft.com/schemaLibrary/2003/core

xmlns:aml=“http://schemas.microsoft.com/aml/2001/core

xmlns:wx=“http://schemas.microsoft.com/office/word/2003/auxHint

xmlns:o=“urn:schemas-microsoft-com:office:office” xmlns:dt=“uuid:C2F41010-65B3-11d1-A29F-00AA00C14882”

w:macrosPresent=“no” w:embeddedObjPresent=“no” w:ocxPresent=“no” xml:space=“preserve”>

<o:DocumentProperties>
<o:Title>Tamino</o:Title>
<o:Author>Dariusz Baumann</o:Author>
<o:LastAuthor>Dariusz Baumann</o:LastAuthor>
<o:Revision>1</o:Revision>
<o:TotalTime>1</o:TotalTime>
<o:Created>2003-12-10T08:40:00Z</o:Created>
<o:LastSaved>2003-12-10T08:41:00Z</o:LastSaved>
<o:Pages>1</o:Pages>
<o:Words>1</o:Words>
<o:Characters>6</o:Characters>
<o:Company>abc</o:Company>
<o:Lines>1</o:Lines>
<o:Paragraphs>1</o:Paragraphs>
<o:CharactersWithSpaces>6</o:CharactersWithSpaces>
<o:Version>11.5604</o:Version>
</o:DocumentProperties>

<w:fonts>
<w:defaultFonts w:ascii=“Times New Roman” w:fareast=“Times New Roman” w:h-ansi=“Times New Roman” w:cs=“Times New Roman”/>
</w:fonts>

<w:styles>
<w:versionOfBuiltInStylenames w:val=“4”/>
<w:latentStyles w:defLockedState=“off” w:latentStyleCount=“156”/>
<w:style w:type=“paragraph” w:default=“on” w:styleId=“Normalny”>
<w:name w:val=“Normal”/>
<wx:uiName wx:val=“Normalny”/>
<w:rPr>
<wx:font wx:val=“Times New Roman”/>
<w:sz w:val=“24”/>
<w:sz-cs w:val=“24”/>
<w:lang w:val=“PL” w:fareast=“PL” w:bidi=“AR-SA”/>
</w:rPr>
</w:style>
<w:style w:type=“character” w:default=“on” w:styleId=“Domylnaczcionkaakapitu”>
<w:name w:val=“Default Paragraph Font”/>
<wx:uiName wx:val=“Domy?lna czcionka akapitu”/>
<w:semiHidden/>
</w:style>
<w:style w:type=“table” w:default=“on” w:styleId=“Standardowy”>
<w:name w:val=“Normal Table”/>
<wx:uiName wx:val=“Standardowy”/>
<w:semiHidden/>
<w:rPr>
<wx:font wx:val=“Times New Roman”/>
</w:rPr>
<w:tblPr>
<w:tblInd w:w=“0” w:type=“dxa”/>
<w:tblCellMar>
<w:top w:w=“0” w:type=“dxa”/>
<w:left w:w=“108” w:type=“dxa”/>
<w:bottom w:w=“0” w:type=“dxa”/>
<w:right w:w=“108” w:type=“dxa”/>
</w:tblCellMar>
</w:tblPr>
</w:style>
<w:style w:type=“list” w:default=“on” w:styleId=“Bezlisty”>
<w:name w:val=“No List”/>
<wx:uiName wx:val=“Bez listy”/>
<w:semiHidden/>
</w:style>
</w:styles>

<w:docPr>
<w:view w:val=“print”/>
<w:zoom w:percent=“100”/>
<w:doNotEmbedSystemFonts/>
<w:proofState w:grammar=“clean”/>
<w:attachedTemplate w:val=""/>
<w:defaultTabStop w:val=“708”/>
<w:hyphenationZone w:val=“425”/>
<w:punctuationKerning/>
<w:characterSpacingControl w:val=“DontCompress”/>
<w:optimizeForBrowser/>
<w:validateAgainstSchema/>
<w:saveInvalidXML w:val=“off”/>
<w:ignoreMixedContent w:val=“off”/>
<w:alwaysShowPlaceholderText w:val=“off”/>
<w:compat>
<w:breakWrappedTables/>
<w:snapToGridInCell/>
<w:wrapTextWithPunct/>
<w:useAsianBreakRules/>
<w:dontGrowAutofit/>
</w:compat>
</w:docPr>

<w:body>
wx:sect
<w:p>
<w:r>
<w:t>Tamino</w:t>
</w:r>
</w:p>
<w:sectPr>
<w:pgSz w:w=“11906” w:h=“16838”/>
<w:pgMar w:top=“1417” w:right=“1417” w:bottom=“1417” w:left=“1417” w:header=“708” w:footer=“708” w:gutter=“0”/>
<w:cols w:space=“708”/>
<w:docGrid w:line-pitch=“360”/>
</w:sectPr>
</wx:sect>
</w:body>

</w:wordDocument>
-----------------------------------

Looking at the response you got when inserting the document…

"--------
ino:response
<ino:message ino:returnvalue=“0”>
ino:messagelinedocument processing started</ino:messageline>
</ino:message>
<ino:object ino:collection=“word2003” ino:doctype=“wordDocument” ino:id=“1”/>
<ino:message ino:returnvalue=“0”>
ino:messagelinedocument processing ended</ino:messageline>
</ino:message>
</ino:response>
-------"

Your document type is “wordDocument” not “w:wordDocument”. What happens if you do an “xql=wordDocument”?

To the best of my knowledge (which is not saying much) xql is not really namespace-aware. Your other queries may well also work if you take out all the "w:"s.

If you need namespace aware querying then try the newer XQuery syntax.

Hope that helps

Mike

Hi Dariusz,

If you want to use X-Query then have a look at the documentation regarding default namespace handling with XQL. From the documentation, following the link “XML Namespaces in Tamino” under the “Special Topics” section, then follow the link “Namespace Handling for Specific XMachine Requests”.

The alternative as Mike Ball suggested is to use XQuery.

Hope this helps.

Stuart Fyffe-Collins
Software AG (UK) Ltd.

According to the sequence mentioned here I defined the schemata.

But I can’t load it in Tamino. The root element wordDocument is missing.

From where did you fetch the xsd files?

Regards, Karl-Heinz.

Hi Karl-Heinz

I think you’ve got hold of a very old thread …

There is a new word 2003 schema available at

http://developer.softwareag.com/tamino/taminoschemaselection/download.htm

I tried this out very succesfully in tamino 441 also with webdav !
Works neatly !!!

Finn