Disabling the default progress bar

I would like to disable the progress bar appearing by default within my table.

My table has input text fields within its rows. Each input text is linked to an invoke action which raises a async hidden command action to retrieve/send some values on change event of some text input. So far, it works fine.
However, I do not want to see the progress bar stating “loading” when a change happens.

The documentation tells that it is possible to do it with
progressDelay: Milliseconds to delay before showing progress bar (defaults to 0). A -1
(negative one) suppresses the progress bar completely.

Progress bar is appearing just before my action begins. Could you please tell me how to set this property on an input text on a table column? Any ideas?


Any ideas?

The display of the progress bar is determined by the settings on the outer-most control that your async command control is refreshing. If your hidden command is refreshing some control that doesn’t support the progressDelay property, then you may need to wrap that control with one of the panel controls that does support that and refresh the panel from your hidden command instead.

Finally got it working with hideable panel. Thanks a lot!