Deploying fileAccessControl.cnf using Deployer.bat

Hi wM Experts,

fileAccessControl.cnf is a file that stored within the WmPublic package and I wanted to have a way to deploy the file to another server. I tried to read the official Deployer User’s Guide but it didn’t give me a concrete answer to where to put the file for it to be deployed using the Deployer.bat.

I’ve tried placing the file under <source_dir>/packages/WmPublic/config, but WmPublic was skipped by the Deployer script. I tried placing the file under the <source_dir>/config folder beside the <source_dir>/packages directory and it still wasn’t picked up for deployment.

I’m stuck on this and maybe someone can help me figure out what is wrong.


packages starting with “Wm” and “Wx” are skipped by default by the Deployer.

Did you check the Appendix D (Deployable Assets) in Deployer Users Guide?
This one is dealing with the different Asset Types, which can be deployed.
There is chapter about IntegrationServer Assets.


I don’t think you’ll be able to deploy something in WmPublic. If you still want to have that file changed I’d recommend to create a service in one of your custom packages; that service would patch the file in WmPublic. You can declare the service as a startup service for the package so that it gets executed automatically. Of course, the service should check whether the file is already patched.

I know, this is not a clean solution, but what should we do if the produc doesn’t allow us to do what we need?


Yes I did, that’s how I got the idea that I can actually deploy fileAccessControl.cnf using the deployer scripts (Page 325). Since this file is not part of the config folder of your IS instance and it is placed inside the WmPublic instance, I’m kinda lost where should I place the file for it to be packaged during build.

I totally agree with you :slight_smile: Actually I have a similar process in mind as a backup in case I can’t make this work.

But it is an Administrative Asset that can be deployed as mentioned in the Deployer’s Uer Guide (Page 325) so there must be a way to do it in a way SoftwareAG meant for it to be deployed.

If you manage to deploy it the “official way”, please post the solution here, I’d be very interested. But I doubt the Deployer supports that since this would mean the Deployer supports modifying the product.

Maybe Command Central could help here.