Deployer : fix dependencies order to load packages

Hi,

In my Deployment, I’ve found another (big) Error :

2016-02-04 16:28:33 CET [ISS.0141.9998E] Exception --> [ISS.0141.9208] Could not deploy the Web service descriptor mifMetier.synchrone.ws.provider:wsBeneficiaires. Cause: [ISC.0081.9181] Cannot find document type mifDocuments.beneficiaire:getBeneficiairesRequest needed to generate WSDL

Nevertheless, I’ve set the dependency on my package mifMetier (which depends on mifDocument), to be sure the mifDocument packages is loaded before mifMetier but the logs show me some strange loading/unloading behaviour :

...
2016-02-05 10:04:58 CET [ISS.0028.0005I] Loading MifMetier package
2016-02-04 16:28:33 CET [ISS.0141.9998E] Exception --> [ISS.0141.9208] Could not deploy the Web service descriptor mifMetier.synchrone.ws.provider:wsBeneficiaires. Cause: [ISC.0081.9181] Cannot find document type mifDocuments.beneficiaire:getBeneficiairesRequest needed to generate WSDL
...
2016-02-05 10:05:00 CET [ISS.0028.0005I] Loading MifMediation package
2016-02-05 10:05:01 CET [ISS.0028.0005I] Loading MifErreurs package
2016-02-05 10:05:01 CET [ISS.0028.0042I] Unloading MifMetier package
2016-02-05 10:05:02 CET [ISS.0028.0005I] Loading MifDocuments package
2016-02-05 10:05:04 CET [ISS.0028.0005I] Loading MifMetier package
...

Is there anything I’m missing to be sure my mifDocument is loaded before my mifMetier package ?

Regards

Sorry, it’s ok.
The server just be had to be restarted.
Regards

I don’t think server restart is required. Reloading the package where your web service provider is located should be fine.

You’re probably right, but in the logs we see the packages had been loaded in the correct order… but then the web services were not accessible until I restarted the IS…

Hi Cedric,

it seems that we experience quite the same problems with IS. :slight_smile:

Error ISS.0141.9208 Could not deploy the Web service descriptor in webMethods Integration Server

In my case, after setting the dependencies correctly and restarting the server the error was solved.

Best regards,
Stefan

1 Like

Add package dependencies to fix this error. No manual restart or reload of package required.

1 Like

Yes, you’re right. for the problem of loading order of the packages, I’ve tested with reloading manually the package, and yes it works.
Thanks
Regards