Default Namespace and XQL queries

I have a requirement where in I need to create an xml with a root tag like this – with a default namespace.

And then, I route this to TN. But, TN XQL queries fail to recognize document attributes.

If i add any namespace to route tag like the below one – It works out fine.

Can you please let me know the solution for this?

I have not worked on this thing, but today I was just watching the properties of developer, there I found an option of default query language for XML node as WQL or XQL…do try to check that.

It comes in tools > options > IS > Flow editor…

Do check it and reply…

when u define xml documents in TN, map the namespaces(prefix used in document, with uri). or otherwise use the same exact prefix used in TN document.

imo, your problem is because

  1. there is no namespace mapping in TN for the document type
  2. using default namespace results in some random prefixes (like v0, tns1 etc)
  3. XQL quesy uses namespace prefix “msts”

So when a xml with default namespace is received, the XQL cannot be evaluated due to point 1.

hope this helps!

Is this issue resolved?
I have a similar issue and the document does not get recognized as it does not have a prefix. i tried to add “prefix0” as the name space with this URI, but no luck.