debugLog using transformer


Can any one let me know why “debugLog” builtIn service is working with direct invoke step but not with transformer?



Hi Soma,
Transfers being used for transforming some value. Now in ‘debugLog’ service you are not transforming any thing and more over if you will check the service you will find no output variable. So how you can use this service as transformer? What you will map to the output variable which is not available. That is why this service can not be used as transformer.

Hi Vikas,

Thanks for your reply.Yes You are right.

We can not use service as a transformer which does not having output data or which does not map output data to pipeline variables


Here is a way to force it to execute:

Expand the transformer.
Under the Service Out, add a string variable. The name can be anything.
Map that variable to a variable in the pipeline.

The transformer will now be executed.

HI Rob,
But still ‘debugLog’ will not work as transformer. Even i tried as well. But reason was not clear to me. If you can tell.

Hi Rob,

Do you mean that instead of using the ‘dubugLog’ as a transformer we need to create a wrapper service for ‘debugLog’ and we should provide some output variable to the wrapper service.
Call this wrapper service as a transformer and the output variable of the transformer should be mapped to any pipeline variable
I have tested like this it is working.

I did not mean create a wrapper service.

Here is a screen shot the shows the results of the steps I posted earlier.

In the similar way i tried but it is not working.

Thanks Rob. I just tried this your way and it did coerce a debugLog transformer to execute.

However, the developer user guide states a transformer won’t run if it has no ‘declared’ output:

If you do not link any output variables or the transformer does not have any declared
output variables, the transformer service will not run.

Just to be safe, it may be better to use a wrapper service.

Thanks for the document reference Sonam. I figured it was mentioned somewhere but I didn’t dig for it deep enough I guess. That’s the answer for the original question!