ConvertToString issue

Hi all,
We’re facing the following problem regarding flat file convertToString service:
We need to generate a flat file with an asterisk “" as content in a field of the document. When this field is the last in the structure, after the conversion the string doesn’t contain the "” character, besides the fact it’s in the document.
If I try to populate this field with any other character, it works, and if I try to populate any other field into the structure it works, even when I use the “*” character.

We’re using IS 6.0.1 and the flatFile Schema is defined as delimited.

Have you guys ever seen such behavior? Is it a bug?

TIA

Renato,

Need some further clarification on your problem.
What are your field, sub-field and record delimiters defined as? What is the position of your record identifier? Is the following a correct interpretation of your problem. If the last field contains “bugsbunny" it becomes “bugsbunny” after the conversion. But anywhere else except the last field it remains as "bugsbunny”?

Chris,

Thanks for your answer.
The record is defined as follows:
Parser = delimiter
Record = newline
Identifier = 0
Actually, in certain conditions, the value of the last field can be “" and after the conversion it becomes empty, and anywhere else it remains "”. Its a single character field (Pos.=149-150).

HTH

Hi,

I just found a different issue on this topic.
I created the FormatService for one of the field in FF dictionary.
However, this service is not executed, does anybody tried to use
that service ?

Do you have the service packs installed for 6.01? There are some flatfile issues addressed.

Renato,

Need some further clarification on your problem.
What is the field delimeter?Did you specify Quoted release character and Release character in schema?If yes what are they? I have tested according to your specification with field delimeter="," and record delimeter=“newline” without specifying quoted release character and release character in schema.It worked fine.The “*” in the last field still presents in the result string even after the conversion.I think it is not a bug.

Hi guys,

Thanks for your responses.
Ray, I have SP2 installed.
Usha, I got no field delimiter and neither of quoted release character or release character, but just record delimiter as newline.
According certain conditions the “*” is mapped into the document.