Connecting to Apache Cassandra

I’m trying out a connection with a Cassandra service that I have running in the cloud.

I’ve tried both via JDBC (big data driver) and via the Adapter for Apache Cassandra.

The adapter just asks for a contact point, but not only do I have a contact point, I also have a username/password and a CA Certificate. There’s nowhere in the configuration on IS that I can use this. Obviously, the connection fails:


[ART.118.5011] Adapter Runtime (Connection): Unable to create new connection prod:thedeal.

com/datastax/driver/core/Cluster$Initializer

The JDBC driver has some more connection properties but the error message isn’t very clear. There’s the option of Trust Store and Key Store but I can’t find any information in the documentation on how to configure my CA Certificate.

Error message here:


[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.

[ADA.1.204] Cannot connect to the database with DataSource class "wm.jdbcx.cassandra.CassandraDataSource40".

[wm][Cassandra JDBC Driver][Cassandra]The server failed to respond to the connection request. Please verify the host and port specified. The non-thrift based Cassandra client port should be used, which on default Cassandra installs is 9042.

Any ideas on how to progress are more than welcome.

This is what I see on a few non-wM forums, Mike; worth a try -

Possible Cause - The local schema files are corrupted or not up to date.

Description - To support SQL access to a noSQL Cassandra database, the DataDirect driver maps the Cassandra data model to a relational schema. The schema map files are saved in the location that is specified by the SchemaMap connection property. The driver looks for this file when it connects to the server. If the file does not exist, the driver creates one.

Resolution - Delete the local schema files and make a new connection. This will rebuild the local schema allowing connections to succeed.

KM

where’s the local schema file? I haven’t even started anything yet… I haven’t managed to make a basic connection.

Unfortunately, I haven’t worked with Cassandra - hope someone else will respond to you.

KM