Comwmappb2bserverServiceException javaioIOException javanetUnknownHostException %2360URL

tried to login to a protected site, using the pub:client:http service.
URL = <https://url>
method = post
data (args):
userID = <userid>
password = <pwd>

When i tried to hit the https website, the following error occured:

An error occurred while tracing. [url=""][/url] 

i tried hitting the same service to a normal website (ie. working fine.
except for this particular website, throwing the above exception.

Anyone faced this error before?

in btw, when i go to IE, and open the particular URL, and login with the relevant credentials, i can enter.

Is there a reason why it’s not accessing the page from IS?

You indicate that the URL is set to:

URL = <https://url>

The error says:

This indicates that the URL is wrong. It cannot find the host named “URL” or “”. If that truly is the hostname (seems unlikely) then try a ping from the command-line to see if you can hit that box. If not, then IS won’t be able to either.

Hi Jennifer. Does your company use a proxy server ? I ran into a similiar problem when I was trying to use pub:client:http service to post across firewalls. After I configured the proxy server everything worked fine. The webMethods Integration Server Administrators Guide will tell you how to set the proxy server. Look for the section “Specifying a Third-Party Proxy Server for Outbound Requests”.



i check the URL. it’s working fine.
Set the proxy server, but seems it cant go through my company’s proxy server.
So i used the dial up instead.
Few attempts could work using the dial up.
But occasionally, my Developer hangs mid-way. When this happens, i try to ping the host’s URL or IP add. But it shows a message:
‘Request Time Out’.

Tried to access the website instead from Internet Explorer, but i could access the website.

Why is it that i can access the page on the website, but not through my IS?

Jennifer, your browser is likely configured to “Use a proxy server”. Have you checked the proxy settings in your browser ? These settings should be used to configure your Proxy Servers in the IS Admin. You may need to restart your IS and Developer after doing this.
If you are not sure about your proxy settings contact your network team.

As I mentioned above, I remember having the same problem trying to use pub.client:http within a flow service across firewalls. Setting the proxy information solved the problem. You will also want to update the Bypass Proxy List if you are testing against localhost.

Wayne 503 Service Unavailable

Just so… that the future users might benefit.

I’ve a URL http://AppServerName:PortNumber/FolderName/ServiceName and need to do a HTTP Post. I got the same error.

Then i modified the URL to include the domain name as http://AppServerName.DomainName.Com:PortNumber/FolderName/ServiceName.

It worked.