[ISS.0026.9104] Missing class services

@M@he$h : It’s a remote server where the webMethods is installed. I don’t find any javac fold. I think there is a problem when they were installing the webMethods

@ t t1030

I guess that might be the root cause for the issue. If you have access to that remote server try installing the JAVA JDK and try out the steps that I suggested.

Let me know if you have any issues/concerns.

Is it mandatory that JVM used for IS is same as used for compiling Java service? I mean is it possible if we run IS on JAVA 1.6 and use Java 1.7 for java service compilation?


On IS extended setting configure watt.server.compile=path of java compiler in your case it should be 1.7

Try this and I assume it should work. Let me know your results.

Hi Mahesh,
Thanks for your reply. But this is what i am not looking for. This i already tried but i am getting error while compiling the java service i.e. [ISS.0026.9104] Missing class .
As soon as i am pointing it back to java 1.6 in extended settings i do not see this error.
That is why i am asking is it mandatory that JVM used for running IS should be same used for compiling the java service?

I think the answer is yes… even we use the same jvm for IS and compiling the java…

Waiting for others to comment on this.

Mahesh, do you have idea or you know if it is documented that wM8.2.1 can use Java 7 ?

Refer system requirements guide at

and also Configuring webMethods Products to Use Java 7 guide.

Oracle Java 1.7.0_13 *1

1 Like

Hi Mahesh,
Thanks for your help. :slight_smile:

Hi Dear:We met the same issue.At last we replace the jar package “ojdbc8.jar” in the path “/opt/softwareag/IntegrationServer/instances/default/lib/jars” and the issue was fixed.

Hi yibo,

this doesnt sound related to the original topic for me.

Can you explain, why this solved your issue?

Generally, the ojdbc8.jar does not need to be located at this central point.
When using JDBC Adapter this can be moved to packages/WmJDBCAdapter/code/jars, making it easier to update it in the future. When placed under packages it is sufficient to reload the Adapter package instead of having to restart the whole IS.

When it is definitely needed under lib/jars, just move it down one level deeper to lib/jars/custom and restart IS.


1 Like