Commerce One OnRamp issue

Hi folks,

We are facing some problems in our production environment and I think the cause is the C1 adapter.
Without any specific reason (we did not find any message in the error or server log - level 10) the C1 stop responding and about 10 minutes after that the IS hangs up. Actually, TN stop responding after C1 and before IS.
We are using IS 4.6 + JVM 1.3.1 + C1 3.0 + TN + BI + SAP/R3 Adapter 4.6.
When C1 hangs all threads has “waiting for monitor entry” status.
I tried many things, but without any success.
Does anyone faced similar problem?

Thanks in advance,


I forgot one detail…
Besides the problem occurs without any specific reason I can force the error.
When I try to see the C1 error log (through C1 admin page) it causes the same problem.
I unsuccessfully tried to find the error log file in the package installation directory.


Renato - we’ve seen similar issues. Make sure the patch level of your C1 OnRamp is up to date - the C1 OnRamp 3.0 patches exist all the way to patch #27.

Once they have been installed, your C1 OnRamp about page should say this:

Product webMethods B2B OnRamp for Commerce One MarketSite
Version 3.0.21
Build Number 79


Thanks for your help
Just to keep you posted, we applied all fixes that webMethods sent us (SP1 and SP2), but it did not solve the problem.
Our customer decided for recreating the webMethods database and it worked!!!


Glad to help Renato. The SP1 and SP2 you described seem like IS service packs. The C1 OnRamp has it’s own set of patches which I described - do ensure those patches are installed too - they’re pretty crucial.