Client FTP get from Integration Server

I have a client that wants to obtain data from our Integration Server using ftp and a “get” command, meaning they want to initiate the session. Can Integration Server pass data back to a client doing an FTP session to IS? How?

If they want to initiate a session, then all you need is to expose a folder containing files of interest for them to come and get the file.

The FTP server in WM is not a full FTP system that provides remote access to file systems.

(It has been a while, but as best I remember.)

Once someone logs to an FTP port, they must navigate through the SERVICE Folders (not file directories) via the CD command. Then do a GET using the service name. That invokes the service, which must be setup to send the appropriate data to the caller.

If you really want to send files from the host file system, you should use a “real” FTP server package.

Problem is, when I do a get, IS is not running the service I created, it will run if I do a “put” however. When I do a “get” I receive a “no such file or directory”, even if I put a file in the ns/directoryname folder that matches the get request. Any thoughts?

OK. WebMethods FTP is virtual in nature and mostly receive only. That is why put works then it invokes your service. This is for inbound documents with session iniated by your client. For outbound you need to use pub.client:ftp for seesions initiated by you. If your client is initiating the session (starting FTP) trying to get file from you, you need to use either unix FTP or windows FTP or some other FTP server. You can have your webMethods server write it to a location under this FTP server and client can pick it up.

Which ftp server is built in webmethods?

webMethods Integration Server supports the FTP protocol but
it isn’t really a “true” FTP server. It may have the core of
some FTP product, or be derived from public domain or open
source FTP package but I don’t know what specifically what
it might be. Why do you ask? Would knowing what it is based
on help with something you’re trying to do?

Hi All,

Here we are using wmDB package.I am getting one error after

i invoked call service in DB package(ORA-06550: line 1, column 7:
PLS-00201: identifier ‘PACKAGENAME.PROCEDURENAME’ must be declared
ORA-06550: line 1, column 7:
PL/SQL: Statement ignored).We have storedProcedure in one Package.

I set up parameters $dbSchemapattern,$dbProc(Here i set up packageName.storedProcedure where my stored procedure located)

then i set up parameters for $dbProcSig where input parameters of stored
Procedurer.I have given values from my flow to $data parameter in call
service.when i run the service i got above error.Is it webmethds
not accepts packagename.procedurename in $dbProc parameter.Pl
Help.

Thanks,
Srini

It should follow with fully qualified service name.

Folder:storedProcedure

or

if you are using multiple folders in a package then

Folder1.Folder2:storedprocedure

HTH.

PackageName means database packageName.My storedProcedure is inside
database Package.I have given parameter $dbSchemaPattern as
SchemaName in that database.Is it Previllages problem.Here this
Service not recognising storedProcedure name.That is in Package.
so i set parameter $dbProc is database PackageName.storedProcedure
Name.When i looked into stored procedure it contains parameters
Batch_ID (in) which is number,As_Of_Dt which is date,other two
fields are VarChar’s.I set up parameter’s for $dbProcSig as
Batch_ID(name) sqlType as BIGINT- direction in,
As-OF_Dt (name)sqlType as DATE – direction in,
other two parameters sqlType as VARCHAR direction in.

i passed values in $data for Batch_Id = 34564,
As_Of_Dt = 01-MAY-2003,Other Two fields values are --N,N.
Similarly i set up $dbParamsByOrder as false.
when i run this service i am getting above error.

I am passing Batch_Id,As_Of_Dt field values into
database insert service before invoking pub.call
service .This service is working fine.Record is inserted into
Database.Pl give me any solution.

Thanks,
Srini

Now Problem rectified.Here is my schema name say: PQT.My database
PackageName is pkg_demand_points.my procedureName is batch_load.
Earlier i have taken PQT(schema name ) as a parameter for
$dbSchemaPattern.pkg_demand_points.batch_load(packageName.storedProce
-dureName ) for $dbProc according to webmethods documentation.
It is not working.Today i changed parameter for $dbProc as
schemaName.packageName.procedureName(i.e PQT.pkg_demand_points.batch
-_load).I deleted setting parameter for $dbSchemaPattern.Then
it works.According to documentation call service returns
$dbMessage .It is not returning that parameter.If my stored
-Procedure inserts into sevaral tables service returns
$update,update parameter’s only.Is it bug???

Thanks,
Srini