Centrasite users list not displayed


We have a Centrasite installation which haven’t been modified lately. I was just about to add a new users and found that the Centrasite user list in the Administration window is missing… Do you have any idea why? Is there some workaround, could users be managed from some other view?

Attached is a screenshot.

The same in the Technical/Business view.

Centrasiteusersmissing.bmp (1.16 MB)

I really don’t know. Anyway, you can try to execute the following query: http://localhost:53305/CentraSite/CentraSite/ino:security?_XQL=ino%3Agroup. When prompted for user and password, enter the same t2sthlm\marhanss credentials used for CentraSite Control.

If you get access denied, then I guess it’s that t2sthlm\marhanss is not in the admin group. Otherwise, the result should be the list of roles (ino:group) that should appear on CentraSite Control, along with the users in each one.

If you can see the list of ino:group, still you could try to manually issue XQueries to alter these groups, which would effectively alter the permissions. Of course you should take care.

Hope this helps

Hi MariaH,
to be more specific, you might try http://localhost:53305/CentraSite/CentraSite/ino:security?_XQL=ino:group[@ino:docname="CentraSiteAdmin"] and use the user DefaultUser with the appropriate password to get this list. If your user name is not in it, you should log in with a user name that is in the list. User XQuery to add a user is possible but not recommended (and documented) this it is rather error-prone.

I seem to be both in the CentraSiteAdmin and CentraSiteUser group. Any other ideas?

<ino:group ino:docname=“CentraSiteAdmin” ino:groupname=“CentraSiteAdmin” ino:id=“1”>


<ino:group ino:docname=“CentraSiteUser” ino:groupname=“CentraSiteUser” ino:id=“5”>


Really not. Anyway maybe you could try things to find out more about the issue:

  • Have a look at the log files at C:\Documents and Settings\All Users\Application Data\Software AG\log\Tomcat\v5.5\
  • Use tcpmon to sniff the traffic between the application server layer and the DB layer. For this:
    –Start tcpmon, listening at some port “X” and redirecting to localhost:53305
    –Edit C:\Program Files\CentraSite\CentraSite 3.1\apache\htdocs\INMconfiguration\INMConfiguration.xml and replace 53305 by port “X”
    –Restart SAG Common Tomcat

Hope this helps


restarting Tomcat solved it, easy! thanks!