Can't view process instance in MWS monitor (7.1.2)

I have created a simple process model with the only activity is to send out an email to me (plus a receive and a terminate step).
I have built and uploaded the process to IS server.
I could login My WebMethods home page and saw my uploaded process in Administration | Process | Business Process tab. I have enabled the process there.

Then I triggered the process by sending the document to the process and I actually got the email sent to me.
So I knew the process was run, but when I went to MWS | Monitor | Process | Process Instance tab, I saw nothing. I searched for all the instances, but still got nothing other than some failed process instances of some other process model I built earlier.

I went back to the Administration |Process | Business Process to view the details of my process model, I noticed its “used” field is No.
I don’t know whether the problem is in my process model, my deployment of the process, or with WMS configuration. I am using 7.1.2.

Any suggestion or help will be very appreciated.

Hi Eric,

Have you give fuctional and access privilages for the user (e.g. Administrator) for the process ?

Cheers,
Samrit

Thanks for the quick response.
I certainly did not set fuctional and access privilages of the process to the user, which is Administrator.
I must have missed that in the documentation.
I will go back and look for that piece of information.

It seems that access and functional Privilages are not the causes of my problem.

I found out the “Administrator” user has a default role of “My webmethods Administrators” and that role already has the default Access and Functional previliges to all the pages (not changable either).
However in the Administration | Roles | Data Level Security | Business Porcess tab, I could associate processes to this role. So I added the selection of “Access to All processes”.

However, with this change and re-logined Administrator to MWS page, I still could not view or search any completed Process Instance. All I could see was some failed and stopped process instance.

Currently, this process is the only one that is enabled in webMethod server, but why this one is not “used” even though I still could receive emails sent out by this process.

hey …did u enabled the IS extended setting to store data to database,watt.auditstore=database.

This should resolve your issue…

Cheers,
Samrit

Samrit,
Thanks again for your tips.
I’ve added the IS extedned setting as you instructed, restarted IS server, but still saw nothing in the Process Instance tab.
I probably still missed something else in the configurations.
I will go back to the Logging and Monitor documentation and hopefully I will figure out what I missed.

Have u configured the jdbc pool setting to the proper database ?

Hi Eric,
Make sure, you have set the audit store setting as below in Extended settings.

watt.server.auditStore=database

Hi Eric,

Did this issue resolved ? I am also facing same problem .

Hi

Go to the IS-> Packages->Management->WmMonitor
Click on the home page of WmMonitor package and check the your MWS details are provided correctly or not.

I hope this will help you.

Regards,
Pranith

Thanks for all the suggestions. I was re-assigned to other higher priority project a couple of weeks ago so I did not have the chance to resolve the problem. I have made sure my jdbc pools setting are configured properly and the WMS details looks ok to me. Still no luck. I will continue to try on my spare time and post here if I got it working.

Hi Eric

Any luck? I am facing the same issue

Well watt.server.auditStore=database is deprecated as per 7.1.2.

Now this is simply configured from JDBC pool aliases definitions.

There is a double communication to check if the user is entitled to display processes.

MWS communicates with the configured IntegrationServer monitor services, and this services comunicates to the configured MWS in the Monitor package to check user privleges , so as Pranith explained you need to check MWS host:port and user/password defined on IN in IS-> Packages->Management->WmMonitor which by default points to localhost:8585 Administrator/manage.

If youe MWS is on a different host, that explain why is not working.

Also if you enable Monitor logging facilities on IS you will get additional information for the error.

Regards.

Hi
Thanks for your reply. However I have done and verified all the steps mentioned in this thread. It does not help. I am able to see in the server logs that the process instance is getting created and completed successfully.
eg:
[PRT.0101.0202I] (T3) completed process successfully PID 0985bb60e9c211de8705e4c4a83e5ef1:1, MID <modelid --removed to maintain confidentiality>However in MWS in Monitoring on searching for this process model it says no Matches Found.

Few important observations:

1) I have upgraded the model from 6.1 to 7.1.2 using the import facility of Designer
2) In MWS Administration: When i goto Business–>Business Process and click on the process model it shows Used: No.
3) Also when I was trying to enable it for execution from this page and trying to save it, it would not show as Enabled for execution, I used service wm.prt.monitor:setModelEnabled to enable the model
4) I read in an unanswerd wmusers post : http://wmusers.com/forum/showthread.php?t=17436 that webmethods inserts duplicates in the table WmProcessDefinition. And this may cause MWS to get confused and not display the process instance??

If any of these observations ring a bell, please post your reply.

Regards

When a process run, in order to be monitored you need:

1- Been able writing to database.
2- Been able to read and display information from database.

We guided you thru the steps to been able to read and display information from database, however maybe the first step is to check if you are been able to WRITE this information to database.

Now in order to WRITE to database you must make sure of the following:

1- In 7.1.2 I faced with an anoying issue, if a JDBC pool is configured to “database” instead of “none” (File), then all pools must be configured to DATABASE. Looks like it does not support to send some to file, and others to database, must be ALL to file, or ALL to database.

Therefore ensure you have all configured pools pointing to database, and of course ProcessAudit and ProcessEngine ( but also ISInternal and ISCore audit ).

2- Edit your process in Designer and , under Runtime tab (QoS) you have NOT selected logging level to “1-None”.

Restart IS as required, or re-deploy process if you need to change any setting.

If this still does not work, go to IS settins -> Logging -> and enable Monitor and Monitor(Database) facilities. This should give you more detailed information from what is happening.

However my bet is you have some JDBC pools to file and others to database, hitting the anoying “defect”.

No respite!
I checked that all stores were set to DB pool. I verified in the backend database in WMProcessdefinition table, it indeed had duplicate entries for the same model.
I deleted one entry but still to no avail…

Weird… execute from developer this services:

WmMonitor/pub.monitor.process.model:getModelNames
WmMonitor/ws.monitor.process.model:getAllProcessModels

Do you get any data?

Yes I can see list of all my models by running these services.

You have data inside database then :smiley:

MWS executes service WmMonitor/ws.monitor.process.model:getAllProcessModels so… you must have some communication issue between both.

Long ago I used a porlet called SoapMonitor to display request/responses between MWS and IS, but it had to be manually installed and I do not remember how.

Raise a ticket with support to get additional traces on this.

thanks… but this still doesnot explain why MWS wouldnt let me enable the model for execution from the Administration page.