Can't see WmSAP package in the list of packages after installation

Hello,
I’m trying to reinstall SAP adapter 10.1 on 10.15 IS. The installation goes OK from CCE but I don’t see the WmSAP package getting added to the list of packages.
Earlier, I uninstalled the SAP adapter as even after placing the jars received from the SAP side, wm.sap.admin class not found errors thrown during loading of the WmSAP package startup services. (registerAdapter startup service was failing). And I deleted the WmSAP package before reinstalling.
P.S: The SAP adapter package was running when I installed the first time and after placing the respective jars.The errors with the startup services started after the migration utility completion from the v10.1 to 10.15.
Any solution is greatly appreciated.

This is the documented installation procedure: https://documentation.softwareag.com/webmethods/adapters_estandards/Adapters/SAP/SAP_10-1/10-1_Adapter_for_SAP_webhelp/#page/sap-webhelp%2Fto-install_5.html%23

The system requirements are specified here: https://documentation.softwareag.com/webmethods/adapters_estandards/Adapters/webMethods_Adapters_System_Requirements.pdf

What’s your OS?
Can you please check that the 3 specified SAP libraries are placed in the specified location?
Are they in the expected version (JCo 3.1) ?
If you’re on Linux, is LD_LIBRARY_PATH correctly set?

Hello Stephane,

I have placed the 3 jars (sapidoc3(packages_directory
\WmSAP\code\jars\static), sapjco3(packages_directory
\WmSAP\code\jars\static) and libsapjco3.so(Integration Server_directory
\instances\instance_name\lib)). This worked and I got the SAP adapter running before the migration utility. After completion of the utility, the errors started even though the jars were still in place.
That’s when I tried the uninstall and reinstall, the installation getting successful but can’t see WmSAP package under packages.
IS is running on Linux v9 on Azure.
Do you mean the checking the PATH variable or some other variable?

Please try with JCo 3.1.8 or later.
I assume the pre upgrade version worked with the old JCo libraries, but the post upgrade version no longer supports them.

What puzzles me is that the WmSAP package is nowhere to be found in the packages after a successful installation. Do you know why is that?

I’ve got no possible explanation for that. You should probably open a support ticket to report this issue.

Hi Venkat,

as this package has a dependency on a native lib, it is required to shutdown and restart the IS instance after installing the package (or a fix for it) and placing the jars and the lib in the right locations.
Remember to give the native lib proper execution rights, otherwise it won´t load correctly.

Watch the server.log closely during startup to detect any loading issues related to the SAP Adapter.

Regards,
Holger

The paths are for Windows, so something does not match here

I copied the paths from SAG document, not the actual one.

I kept the IS shut down as instructed in the SAP adapter guide and started once installation is completed. I will check on the rights once again.