can't access to database from IDE eclipse

Hi

I installed Docker Natural Community Edition , i see the database with AdabasManager and it’s running . But , when i lauch exemple program using employees DDM , i get the error as you can see on screen copy.

I changed the DBID of the DDM from 0 to 12 as described in an anoher topic but no change .

Thanks for your anwser .


The error message identifies database 12, so we know that you correctly stowed/built the DDM and program.

Error number 3148 tells us that Natural cannot communicate with DB 12, despite Adabas Manager reporting the database is active.

I have no experience with the Docker installation procedure. Were ONE and Adabas installed at the same time, on the same machine?

I’m glad to see the Docker CE editions have been updated to 9.1.2 and a refreshed license expire date. Maybe this weekend I’ll finally get around to trying to download and install them, if my old spare PC supports the Docker virtualization.

A thought, make sure your Docker command to start the Natural Development server specifies the correct IP address where Adabas is installed.
7. 2 Starting Natural in a Docker Container
The following command starts the Natural container. You have to replace “” in the command with the IP address that you have determined, to have access to the Adabas database.

docker run -d -p 2700:2700 --add-host adabas-db: -e ACCEPT_EULA=Y store/softwareag/natural-ce:9.1.2

Meanwhile, reading through the Adabas & Natural CE for Docker guide, I found this suggested 3148 problem solution on the last page:

12.2 Natural runtime cannot connect to Adabas running in a container
You can connect to the Natural container on port 2700,but Natural applications running in the container cannot connect to the Adabas database,and you are getting error code 3148.
Check first if you have a firewall running on your host machine that is blocking port 60001. Ensure that this port can be reached in your environment.
If this is not the case,it is possible that you have a loopback address access problem in your configuration so that Natural cannot access the Adabas network on port 60001 through the external IP address.

You could fix this problem using a Docker network while starting your containers. To do so, first stop and remove the already started Adabas and Natural Docker containers.

Change your Quickstart commands to the following three commands:

docker network create adabas_natural

docker run -d -e ACCEPT_EULA=Y -e ADADBID=12 -e “ADA_DB_CREATION=demodb” --network adabas_natural --name ADABAS-DBstore/softwareag/adabas-ce:6.7.1

docker run -d -p 2700:2700 --network adabas_natural -e ACCEPT_EULA=Y store/softwareag/natural-ce:9.1.2

Hope that helps. Please let us know.
Thanks,
George

Hi

I followed your instructions creating a docker network but without success and always the same error . I read carefully the install doc and found that i’ve to create a mapping file inside the container docker adabas , so i do that and restart the container but during the adabas’s container startup , i get the message " mapping file found but database unreachable by TCP/IP and at the end , the database becomes inactive . if i remove the mapping file and restart the container , database gets active.

Very strange.

So , for now , I’m stuck but I’m going to get on .

Thanks for answer .

do you have a dbmapping.txt file? Adabas TCP needs this to map the dbid to a TCP/IP address and port.

The file is located in the AdabasClient/config directory (/Adabas/Client/config/dbmapping.txt). You need a line in there with
= adatcp://:
If Adabas and Natural are running in the same container, then this line in dbmapping.txt might be:
012 = adatcp://localhost:60001

Hi

yes i add a dbmapping file as the getting started guide describe it but it failed with the same error .But i see in the adabas manager some access to the database 12 open command and close command .

So i’m going to stop to spend time to get it work .

Thanks for help

BR

HI

After a last try , it works !!! . As we can read in lot’s of reply in forums , solution was to RTFM . So , i don’t know if it’s important , but the guide tells to install docker-ce and I installed docker from repository stable debian buster . Following guide instructions , I remove my docker version and install docker-ce and it’s all .

BR

Hi Eric,

Congratulations for finding the solution to your problem. I’m glad to hear you got it working, and what the problem was. Thanks for updating us with your solution.

Cheers,
George