Cannot connect to TAMINO....java.lang.NoClassDefFoundError:

Hi all,
I am new to TAMINO and also this is my first try in making an application using java…i m using JBUILDER9 for my java code and my code is as follow:

package serial_tamino;

import com.softwareag.tamino.db.api.accessor.TSystemAccessor;
import com.softwareag.tamino.db.api.connection.TConnection;
import com.softwareag.tamino.db.api.accessor.TAccessorException;
import com.softwareag.tamino.db.api.connection.TConnectionFactory;
import com.softwareag.tamino.db.api.common.TException;
import java.io.FileNotFoundException;
import java.io.InputStream;
import java.lang.NoClassDefFoundError;
import com.softwareag.tamino.db.api.objectModel.jdom.TJDOMObjectModel;
import com.softwareag.tamino.db.api.objectModel.TXMLObjectFactory;
import com.softwareag.tamino.db.api.objectModel.dom4j.*;
import com.softwareag.tamino.db.api.common.TPreference;
import java.lang.Class;

public class Serial {
// URI of the Tamino database, please edit accordingly
private final static String DATABASE_URI = “http://localhost/tamino/Project_Database”;
// use a system accessor to check if the database is alive and
// print some system information to stdout
protected static boolean checkServerAndPrintSystemInformation(TConnection connection) throws TAccessorException {
// Obtain the TSystemAccesor
TSystemAccessor systemaccessor = connection.newSystemAccessor();

if (!systemaccessor.isServerAlive()) {
return false;
} else {
System.out.println( " server is alive" );
System.out.println( “\nHere is some systeminformation” );
System.out.println( “------------------------------\n” );
System.out.println( "The Tamino server hosting " + DATABASE_URI +
" is version " + systemaccessor.getServerVersion() );
System.out.println( "(Server API version: " + systemaccessor.getServerAPIVersion() +
", Tamino API for Java version: " + systemaccessor.getAPIVersion() +
“)\n” );
return true;
}
}
public static void main(String[] args) throws TException {

// Print out a program header to stdout
System.out.println( “\n Serial Program” );
System.out.println( “========================================” );
System.out.print( "Connecting to Tamino database " + DATABASE_URI + “, …” );

// Obtain the connection factory
TConnectionFactory connectionFactory = TConnectionFactory.getInstance();
// and obtain the connection to the database
TConnection connection = connectionFactory.newConnection( DATABASE_URI );

// Check if the connection is available and print out some system information
if ( !Serial.checkServerAndPrintSystemInformation( connection ) )
return;
}

}


this is just my first step…and when i m trying to run this program…it gives me the error as
Serial Program

========================================

Connecting to Tamino database http://localhost/tamino/Project_Database, …java.lang.NoClassDefFoundError: org.jdom.Document

at com.softwareag.tamino.db.api.objectModel.jdom.TJDOMObjectModel.class$(Unknown Source)

at com.softwareag.tamino.db.api.objectModel.jdom.TJDOMObjectModel.(Unknown Source)

at com.softwareag.tamino.db.api.objectModel.jdom.TJDOMObjectModel.getInstance(Unknown Source)

at com.softwareag.tamino.db.api.objectModel.TXMLObjectFactory.(Unknown Source)

at com.softwareag.tamino.db.api.objectModel.TXMLObjectFactory.getInstance(Unknown Source)

at com.softwareag.tamino.db.api.objectModel.TXMLObject.(Unknown Source)

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Class.java:140)

at com.softwareag.tamino.db.api.objectModel.dom.TDOMObjectModel.class$(Unknown Source)

at com.softwareag.tamino.db.api.objectModel.dom.TDOMObjectModel.(Unknown Source)

at com.softwareag.tamino.db.api.objectModel.dom.TDOMObjectModel.getInstance(Unknown Source)

at com.softwareag.tamino.db.api.common.TPreference.(Unknown Source)

at com.softwareag.tamino.db.api.common.TPreference.getInstance(Unknown Source)

at com.softwareag.tamino.db.api.connection.TConnectionFactory.(Unknown Source)

at com.softwareag.tamino.db.api.connection.TConnectionFactory.(Unknown Source)

at serial_tamino.Serial.main(Serial.java:57)

Exception in thread “main”


I cant really figure out how can i fix this problem…i have included the examples,library and all from the taminoAPI4J…but still nothin seems to work…CAN SOMEONE PLEASEEEEEEEEEEEEE HELP ME…as i m just in the beginnin and i have a longgggggggg way to go :cry:
thanks in advance…i hope someone will help me… :roll:
Regards,
Shuch

i found a way myself…i just have to add two more libraries in my CLASS-PATH namely,jdom.jar and xml-apis.jar…
finally it works fine…