Canbt access WmBrokerAdmin package

Recently, I have seen three instances in which the WmBrokerAdmin package can not be accessed from IS.

After logging into IS Administrator and clicking on the WmBrokerAdmin packages’ home icon, the login dialog box is displayed repeatedly (no matter what login credentials you enter).

Normal behavior is for the home page of the WmBrokerAdmin package to be displayed without any additional login prompts.

We have attempted a number of things to isolate the cause of the problem including checking ACL’s, .access files, reinstalling the package, reinstalling IS and Broker, etc.

We can use WmBrokerAdmin from other IS servers to connect to and administer the broker in question, just not the package installed on the IS server on the same box as the broker. Several other IS/Broker installations performed from the same Installer image on the same project have not had this problem.

In one of these cases the WmBrokerAdmin package worked initially, but had this issue after uninstalling and reinstalling IS.

Has anyone seen this before? If so, what was the solution? I do have an SR into WM tech services but wanted to tap into the great minds here at WM Users as well.


I have used wmBrokerAdmin packages for monitoring Broker running on the same solaris box but at times WmBrokerAdmin package would not come up and I had to manage that Broker from another IS’s Broker packages
It happed few times.
Reloading WmBrokerAdmin package has helped .

What do you mean by “would not come up”? Did you get a login dialog box or some other error?


I believe that there is a fix from Technical Services for this particular problem with the 6.1 Broker Admin.

The issue is addressed by “WmBrokerAdmin Fix 1”. It addresses this login issue (which apparently occurs when using the default users and passwords) as well as several other issues.

Thanks again Dave!


Well, I spoke (OK, typed) too soon. The WmBrokerAdmin Fix 1 did not address my issue. I’m sure it does other good things though.


The fix from Tech Services was to 1) delete the files beginning with ACL* from the <is_dir>\config folder and 2) replace the .access file the the \packages\WmBrokerAdmin\pub folder.

One of these two things did the trick.

The real question remains: “Why did this occur on a fresh install made on the IS server using the webMethods Installer with an install image?”. Support had seen something similar when PC Anywhere was used to perform installs, but never with Installer alone.

Also “Why did five machines installed with the same process work fine, but a sixth server have this problem?”


I faced this problem too. And, for us “Fix 1” didnt help. Also, .access file in WmBrokerAdmin package was not corrupt either.

We got around this one by following these steps

  1. manually creating the Broker user with default password
  2. then creating the BrokerAdministrators Group
  3. Assign Broker user to the group just created
  4. Create the BrokerAdministrators ACL
  5. Have Administrators and BrokerAdministrators as allowed groups for this ACL

I have no idea why seemingly “successful” install doesnt create these users,groups and acls!!

We had both IS and Broker installed on the same box.



We experienced the exact same problem and Saurabh’s manual workaround fixed the problem. Thanks very much.


Good to know that, Ian.

I just hope that webMethods looks into this “bug” and possibly fix it in their next version of the installer.

  • Saurabh.

Thanks for the post Saurabh. Your manual fix worked its magic for me too.

Good to know that, Will.

does this mean that the issue has not been fixed yet!! (its more than 6 months now)

Or were you installing an older version of the package?

  • Saurabh

I’ve installed version 6.1.

Not sure if there are any patches out there for the same.

Thank you so much Saurabh …

This has really worked for me and saved my time as well.

Hi All,
I have one issue with my BrokerAdmin page. I am able to see the brokerpage but the brokername is not a href so that i can click on it and see the client groups, doc types etc etc. Is there any fix for this tooo. Please let me know.


Hi All,

I am trying to register content handler for multipart/form-data in my IntegrationServer by using the code.

Code:“multipart/form-data”, new;

But I am getting exception while compiling the java service:

package does not exist“multipart/form-data”, new;
1 error

Please help me to get rid of this issue.

I am in the process of receive and process of multipart/form-data. Now I am not able to receive any data in the receiving service.

Thanks in advance.