can not open service

hi wmusers.

i have a problem opening the service from the developer. When i try to open the service, developer goes hang.
i validate the xml file of the service, i found that the xml file is valid.
the big problem is when i face this problem on Production Server, i will face it also on Development and Training machine or the other Servers that have the same service.
i tried to open the service from the other computer. But i still get the same problem.

i have try to debug (LEVEL 10) the developer. i found this message.

2010-02-04 10:59:56 PST [ISU.0000.9999V6]
2010-02-04 10:59:56 PST [ISC.0064.0015V2] Opening Socket
2010-02-04 10:59:56 PST [ISC.0038.0002V3] --> POST /wm-message HTTP/1.0
2010-02-04 10:59:56 PST [ISC.0038.0002V3] --> User-Agent: webMethods
2010-02-04 10:59:56 PST [ISC.0038.0002V3] --> Accept: image/gif, */*
2010-02-04 10:59:56 PST [ISC.0038.0002V3] --> Host:
2010-02-04 10:59:56 PST [ISC.0038.0002V3] --> Authorization: Basic c2lzaW5kb2tvbTpzaXNpbmRva29t
2010-02-04 10:59:56 PST [ISC.0038.0002V3] --> Cookie: ssnid=432456FY4nKstisUix6EkZu6EBQyKdB3c-555542
2010-02-04 10:59:56 PST [ISC.0038.0002V3] --> Content-Type: application/x-wmidatabin
2010-02-04 10:59:56 PST [ISC.0038.0002V3] --> Accept-Language: en-US
2010-02-04 10:59:56 PST [ISC.0038.0002V3] --> Content-Length: 412
2010-02-04 10:59:57 PST [ISC.0040.0001V3] HTTP/1.0 200
2010-02-04 10:59:57 PST [ISC.0038.0002V3] <-- Content-Type: text/html; charset=UTF-8
2010-02-04 10:59:57 PST [ISC.0038.0002V3] <-- Connection: Close
2010-02-04 10:59:57 PST [ISC.0038.0002V3] <-- Content-Length: 4044404

For your information:
Developer version : 6.5.
Updates: ID_6-5_SP3_Fix6;ID_6-5_SP3

has anyone had experience with this problem?
how do i solve it?

thank you.


Content-Length: 4044404

That’s pretty big. Is the service really over 4 million bytes in size?

the physical size itselt is 2MB.

$ pwd
$ ls -l
total 11072
-rw-r--r--   1 wmadmin  weboper     2830330 Jan 14 12:20 flow.xml
-rw-r--r--   1 wmadmin  weboper     2830585 Jan 14 12:15 flow.xml.bak
-rw-r--r--   1 wmadmin  weboper        2556 Jan 14 12:20 node.ndf

Invoking this service from the other serivce is fine.
have you any idea?


I saw something similar several years ago when there was an unreliable network connection between Developer and one of the IS servers we were using. Other servers would work fine, but opening a large IS service on a specific server would result in a developer freeze.


last week, we created a change on service in PRODUCTION server. after saving the change we got the developer freeze.
i tried to open the same service on the other server (development and trining). i got also the same problem.
if it come from the large value of service. how about the other service? i have an other service called with the same size (2396549 bytes). developer is fine opening this service.

for your information. It is fine on IS 7.1.2 and developer 7.1.2.
i haved copied the package to IS 7.1.2. opening the service from developer 7.1.2 is fine.


Sounds like it’s time to engage tech support.