calling Oracle procedure in IS 4.6

I am trying to call an Oracle stored procedure that has in and out parameters from Developer on IS 4.6, using builtIn call service.

At runtime, I am getting error message that the parameter is not defined. It seems to me that the IS is sending all the variables in the pipeline to the stored procedure even though they are not defined in dbProcSig.

Could you some tell if I did something wrong or there is a bug. Is there any work around? Please give me some code example if possible.

Thanks a lot.

Are you using Oracle Apps Adapter?

I am using Developer on Integration Server 4.6.

I am having exactly the same problem in IS. I concur that everything in the pipeline is being passed to the procedure, hence why I get the following error: [B2BSERV.0026.9103] No parameter named deDupeOrSort

(where deDupeOrSort is a parameter in my pipeline!)

The interesting thing is that if I put a Map step immediately before the “call” step to the Stored Procedure to DROP everything except $dbAlias and $dbConnection, I get the same error refering to a different pipeline variable (rowCount): [B2BSERV.0026.9103] No parameter named rowCount

However, rowCount was one of the variables I dropped in the “drop” Map step.

This is definately a bug!

Sorry that doesn’t help anyone but hopefully it reaffirms the original observation.

Hi Experts,

Can someone please help me in invoking an SP using Oracle Apps Adapter?
I created a transaction and then created an adapter service but when I run the service, I am getting below error?

[ADA.400.118] $dbProcSig missing from transaction definition.

How do you specify input/output of the SP in Oracle Apps Adapter implementation?

Any direction/screenshot/steps in this regard would be a great help. Thanks!