Calling a WM web service using dotNet

I get an server error on IS when trying to call a web service using Microsoft dotNet. I imported the (RPC) wsdl into dotNet and it created classes for the documents it uses for input and output variables.

Any idea why this is happening?

The server error on the IntegrationServer:

[ISC.0088.0001E] SOAPException: [ISS.0088.9135] A WMDocument Exception was thrown in the server, usually because an XML block was not well-formed

The error I got at the same time in the dotNet environment was:

There was an error generating the XML document.
at System.Xml.Serialization.XmlSerializer.Serialize(XmlWriter xmlWriter, Object o, XmlSerializerNamespaces namespaces, String encodingStyle)
at System.Xml.Serialization.XmlSerializer.Serialize(XmlWriter xmlWriter, Object o, XmlSerializerNamespaces namespaces)
etc…

Can you capture the soap message going to the IS server to see if the message format matches the format the IS Flow service is matching? Use a tool like http://www.pocketsoap.com/tcpTrace. It will let to capture the packet as it appears going to the IS server.

Most likely you are not sending the correct number or types of parameters the RPC service expects or your namespaces are not correct. Either way the soap message will show you what is incorrect.

As a side note, I would look at using a doc/literal web service as oppose to a rpc based one. More flexible, easier to use in .Net and its pretty much the standard in web services land.

Thank you for your reply, I tried using tcpTrace and the SharePoint server got in the way. I’ll try it some more.

You say it is easier to use document/literal in dotNet, can you please brief me shortly on how to do that. I’m pretty sure I managed to create a legal document/literal wsdl which I consumed with dotNet but looking at the Web Reference I can’t see the method I created like when using RPC.

I’m pretty stranded now and I couldn’t find any tutorials or demos to help me with this so I went back to the RPC format.

This will take you to a sample package - http://www.wmusers.com/forum/showthread.php?t=6525 . Be sure to look at all of the documents structures, fields and flow service attributes to understand how the namespaces and soap structure get created. It can be a bit confusing when getting started but once you are there it will be easier to work with in .Net.

Thank you, I’m going to test this now.

Hi,

I am getting same error while invoking a webService on oracle 10.1.3 using soap 1.1 doc/literal.

Problem is whenever i restart server it works fine and then after some tries again goes into problem

Its 7.1.1 IS and with following fixes
IS_7-1-1_SrvPrtcl_Fix4
IS_7-1-1_WebSvcsXML_Fix3

Appreciate any help…