CAF Dropdown list problem

Hi Im new to CAF area…I have a UI which worked fine when run in MWS, WM7.1.3 versions.having upgraded to WM and MWS 8.2 , the same UI that has one of the fields- dropdown list appears empty, if I republish to server from Designer and then refresh the page it is populated , but when logged in for the first time list appears empty…I would appreciate any help/assistance .let me knwo if more info needed.

Probably one of the first things you could investigate, is how that drop down list is supposed to be populated. Do the results come from a web service client? If so, is that web service client set to auto-refresh?


Results are populated in the list from a Database Query, the contents are comma seperated example: abscd, wejr . does this have anything to do ?reason is I have another listbox fetching the same data ,that also does not get populated.and upon publish from Designer and then refresh brings them back to the way it is in 7.1.3

What is the value of the autoRefresh property for the RowSetTableContentProvider?

Is it true?

I have autorefresh set true for the DataBinding under DataBindingsummary for the query configured(value of this is set in OptionGroup under Dropdown-> Choices).
I could not find specificly RowSetTableContentProvider.Does this need to be added as property?

The Database Connector is an instance of RowSetTableContentProvider, and that is good that the Auto Refresh is set to true.

I just built a couple of DB Connectors, one bound to a table and one bound to an option group and they worked fine.

Could you try to create a quick portlet app from scratch and add a DB connector to see if you get the same behavior? Maybe there’s a problem with the DB connectors when you build them in Designer 7.x and then bring them forward into Designer 8.x?