[B2BSERV.0014.9116] Unable to locate or start compiler

I have this problem in my DEV environment when trying to compile a Java Service. I already checked my server.sh for JAVA path, .profile of the user, and environment variable and it looks good to me.

Here is the error message in Developer console:
"The source was saved, but was not compiled due to the following errors:

com.wm.app.b2b.server.ServiceException: [B2BSERV.0014.9116] Unable to locate or start compiler"

server.sh

JAVA_ROOT=/usr/j2sdk1_3_1_02/jre

if [ “$1” = “local” ]; then
shift
B2B_ROOT=/opt/webMethods/IntegrationServer4_6
JAVA_PATH=which java
JAVA_ROOT=/usr/j2sdk1_3_1_02/jre
RUNLOCAL=“true”
else
RUNLOCAL=“false”
fi

jcode.sh

#!/bin/sh

B2B_ROOT=/opt/webMethods/IntegrationServer4_6
JAVA_ROOT=/usr/j2sdk1_3_1_02/jre

JCMD="${JAVA_ROOT}/bin/java"

JCMD -cp {B2B_ROOT}/lib/client.jar:{B2B_ROOT}/lib/server.jar com.wm.app.b2b.s erver.NodeUtil {B2B_ROOT} $*

Is there any workaround here? Or is it safe to reinstall IS4.6?

Make sure that your javac.exe is in your path.
Your current path seams to point to the runtime environment, not the
compiler.
Regards,
sf

I think this is a late response to your email, but wanted to share this information with you…

In the /config/server.cnf file, there is a parameter watt.server.compile which will be use to compile your java code. By default, it points to javac -classpath {0} -d {1} {2}.

Change this to /usr/j2sdk1_3_1_02/bin/javac -classpath {0} -d {1} {2} so that it points to your java location (please remember to shutdown your IS before editing the server.cnf file, otherwise your changes will not be saved).

Best of luck!!

Hi,

I already did that step, shutdown IS before changing the server.cnf file and I still get this error. What I did before is backup all the files and packages and uninstall IS and then reinstall. The problem goes away and I was able to compile the Java services several times. And then after 3 hours, the problem suddenly exist again.

Here is my server.cnf file:

watt.server.compile=/usr/j2sdk1_3_1_02/bin/javac -classpath {0} -d {1} {2}
watt.server.compile.readFromStdErr=true
watt.server.compile.unicode=/usr/j2sdk1_3_1_02/bin/javac -encoding Unicode -classpath {0} -d {1} {2}

server.sh:

B2B_ROOT=/u01/home/wmdev/webMethods/IntegrationServer4
JAVA_ROOT=/usr/j2sdk1_3_1_02/jre

Directory list:

/usr/j2sdk1_3_1_02/jre> ls
bin COPYRIGHT plugin
CHANGES lib README
ControlPanel.html LICENSE Welcome.html
/usr/j2sdk1_3_1_02/jre>

/usr/j2sdk1_3_1_02/bin> ls
appletviewer jar javah oldjava rmiregistry
awt_robot jarsigner javald oldjavac serialver
ControlPanel java javap oldjdb sparc
extcheck java-rmi.cgi jdb policytool tnameserv
HtmlConverter javac keytool rmic
idlj javadoc native2ascii rmid
/usr/j2sdk1_3_1_02/bin>

.profile (UNIX)

This is the default standard profile provided to a user.

They are expected to edit it to meet their own needs.

MAIL=/usr/mail/${LOGNAME:?}
export PS1=’$PWD> ’
export WM_HOME=/opt/webmethods/wmdev/IntegrationServer4

WM_HOME is symlink to B2B_ROOT. did i miss something?

I found out that this error occurs only when I change my Java heap size memory to (min) 512 max (1024) in server.sh.

May be the lack of memory, corrupting your server.sh. Some time back we had some problem with server.sh when we utilized all of our disk space. May be its affecting the configuration files as well, I am not sure…

Anyway, you figured out the problem!!

thanks for the reporting on the memory problem!!!

I had the same problem on Sun Solaris wM 6.1.

I really couldn’t figure out what was wrong. I modified all possible settings and still the message appeared.

After I had shut down another server running on the same machine he was able to compile.