AWS SQS as JMS Provider

Is anybody aware if we can connect to Amazon SQS through webMethods JMS Connection.

I dont think Amazon SQS can be used as JMS Provider.

Either you need to use Cloudstream adaptor for Amazon SQS . I think you may have to write the custom adaptors(if not using cloudstreams) or write the java service and do like a continuous polling.

Using Amamzon SQS with JMS should be possible.

Please check the following links:

Try to place the mentioned jar-files under IntegrationServer/lib/jars/custom and MWS/lib/ext.

Remember that it might be neccessary to shutdown and restart the instances.

Please update the thread with the results.


Hello Holger,

Thanks for the response. I want to try the JAR Files and test connectivity. Do you happen to know the connection parameters i need to use while creating JMS/JNDI Connection?
BTW, i have placed the required JARs in IS, but not sure why i need it in MWS Directory.


Sitikantha , Any luck getting this work?

Were you able to use SQS as JMS Provider ?

Hi All,

We want to connect to the SQS JMS queue from webMethods 8.2.

We have received access key id and secret access key from the administrator. But we are not sure how do we pass this.

We tried creating JNDI lookup and passed URL and Initial Context Factory “”.

We are getting below error:

Caused by: java.lang.reflect.InvocationTargetException: null
Caused by: java.lang.NoClassDefFoundError: com/amazonaws/auth/AWSCredentials
Caused by: java.lang.ClassNotFoundException: com.amazonaws.auth.AWSCredentials

Please let us know if anyone has succesfully connected to the SQS queue.

Thanks in advance.


Hi Akshay,

did you try the following:

Looks like you are missing the libs with classes for AWS SQS.


Hi Holger,

Thanks for the reply, we placed below jar files in the mentioned location. Still we are not able to connect to the SQS queues.

nevado-jms-1.3.1 (tried with and without this jar)

We are now getting “Cannot instantiate class:” error.

Can you also please confirm if below Initial Context Factory configuration is correct:

Initial Context Factory:

Also in my earlier post I mentioned we have Acces Key Id and Secret Access Key, can you please let me know how do we pass this. Is it right way to pass this values in ‘Security Principal/Security Credentials’.

Thanks in advance.


Hi Akshay,

do you have some more details about the “cannot instantiate” error?

There should some information why the class could not be instantiated.

You can introspect the jar-files with any Zip-compatible program to find out the correct name of the ConnectionFactory-class.


Hi Holger,

Thanks for your response, I do not have additional information about “cannot instantiate” error.

Meanwhile, I raised a service request with SAG and got a below reply,

Now, we are left with only option is to create Java Services to subscribe messages from SQS queues.

Please let me know if you have any alternative solution.

Thanks in advance.

Regards ,