audit config Issue

We are facing issue while renaming webMethods server host name in AuditConfig.xml file in our unix OS system at file level

When ever we tried to modify AuditConfig.xml via manually at back end file system and then restart IS
teh old server host name is roll back in file AuditConfig.xml.

Did any one face this issue before or know any fix for same ?

WM 9.7
OS AIX

Try below and let me know if you still have issues.

  1. Edit the AuditConfig.xml and check for the below tag
    hostname:port

  2. Edited the etc/hosts file to add the hostname as an alias for localhost.

  3. Start the IS.

Or

  • Backup and delete AuditConfig.xml
  • Start the IS to see if a new AuditConfig.xml gets created. (Try this on your development server and be little cautious)

Followed Steps 2 to 4
After changing host name and then i restarted IS it’s roll back old host name in AuditConfig.xml file

While i tried deleting AuditConfig.xml but after restart it will recreate AuditConfig.xml again but with old values
ie old server host name

Looks interesting!

Can you write a java service with the below API. Lets check what IS returns as hostname

Java API: “InetAddress.getLocalHost()”

Issue resolved.

new host server name was missed to added at OS level
Hence Issue has been resolved

Hi,

Can you please specify what exactly was changed in OS? Which file?

Mahesh – It is unix admin’s task to add the host details as part of hosts file. You can take it easy.

Thanks,

Mr, 173d,
Thanks for your comments. As mentioned earlier in the thread "3. Edited the etc/hosts file to add the hostname as an alias for localhost. " I have already informed the user to have a look at the hosts file (not sure if you had looked at it first)

I am just trying to understand what other files would include to fix the current issue. If you are aware of the other files kindly share it will be helpful to me and of-course others.

1 Like

Hi MR/Mahesh,

Thanks for response.

Adding WM host name happen at OS level not at WM console/file system.

In my case we have AIX unix box where several IS are running so the OS box where these IS are running at OS level Unix admin team added WM host name which resolved my issue.

I m not sure which file or location unix team is updated

Thanks Vinay for your response. But for confirmation you can send a mail to Unix team asking is the only change to hosts file resolved the issue or any other files updates ?

Thanks,