Applications not visible in API portal trial account

Hello All,

Could someone please let me know whether we have some issues in visibility of applications in API portal. In manage apps, when I create application in API portal, it doesn’t create or provides any option to generate client ID/ Secret, and under ‘applications’ tab in Portal I could not see any option to create application and even applications which I created in API Gateway and API portal (Manage apps) are not visible, hence no client ID /Secret.

Need clarification with this, if this is the case with Trial account or I am doing something wrong here. Please suggest at the earliest.

Sumit Kapoor

Hello Sumit Kapoor,

If you would like to create a application for accessing a API, you should be using the 'Get access token` link in details view


Mange Apps is completely different. It is meant to showcase client applications (if any) you have developed by consuming the APIs.


Hello Arul,

Thanks for your response. What if that particular API is not having Oauth enabled in policies in gateway, so I wont be able to see ‘Get Access Token’ option.

In the API where I enabled Oauth2.0, when I am trying to generate access token from Portal, it says token will be generated but nothing gets generated in trial account on API portal.

Also, say app developer comes and create application, so he should get clientID/Secret to access those APIs, correct ?

Sumit Kapoor

yes. When the API is protected either by APIKey/OAuth/JWT then you will have “Get access token” link in the details page. If the API is not a protected API, then you dont require a application to access it.

Regarding the issue in generation of application you can check below article.
Debuging application requests raised from API Portal - Knowledge base - webMethods - Software AG Tech Community & Forums

Please check the portal destination in API Gateway and update the user name/passwords configured there (if changed)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.