API Gateway did not replace encoded URL for + symbol

The API testhost:testport/{variable} registered on SAG gateway. This is a GET call .
Consumer is invoking the URL sample with the variable value . when routing to the native service i can see that the URL encoding %2B is replaced with a SPACE Example: value(A B) instead of value(A+B) in the url testhost:testport/value(A+B) , The + is getting replaced by a Space.

I used the encoding testhost:testposrt/value(A%2BB)—> Its replacing + with space.

using value%28A%2BB%29 Still the same, the () are replaced but not the +

Default encoding on gateway -application/x-www-form-urlencoded

When calling IS directly A%2BB in the URL, i am able to get the +.

Is this a problem with the default encoding type? any configurations need to be updated on gateway ?

Issue fixed with the below configs :

decodeAllDelimitersInURI set to true on Gateway UI extended setting

watt.server.http.uriPath.decodePlus= false on API Gateway UI and IS .