Allowing lower-case in INPUT

I’m at home and don’t have access to code snippets.

I want to INPUT a JCL jobcard in batch and have it go into a Natural variable, with no converting to UPPER-CASE. It’s English text a user wants put into a comment field.

I tried LC=ON at the top of the program and and AD=W on the INPUT statement, but no luck.

This page says that’s all I need to do, but no luck:




The uppercase translation could be happening in several places. Ensure that your TSO session allows lowercase in your CMSYNIN/SYSIN DD stream. Ensure that your Natural session allows it by setting it on the EXEC statement (PARM=‘UC=OFF’) or once you’re in Natural with the terminal command %L in CMSYNIN (sort of equivalent to Wolfgang’s SET CONTROL suggestion).

Check your INPUT statement for AD=T and change it to AD=W (the default).

SET CONTROL ‘L’ worked.

Thanks Wolfgang!