ALE Listener notification not working

Hi there,

I have a synchronous ALE Listener notification set up which listens for IDOCs of type X sent via RFC destination WEBM_X. Both the SAP listener for program id WEBM_X and the ALE Listener notification are enabled. However, all IDOCs sent from SAP end up in status Rollback with below error:
WmSAP Adapter: Missing notification - MsgType: XMSG (SNDPRN >> RCVPRN).

I double checked with SAP, they are sending IDOCs with correct type via correct RFC destination so I really do not understand why the requests are picked up by the routing listener instead of the ALE Listener Notification.

Do you have any idea what else can be checked?
Needless to say, that I already tried to enable/disable the sap connection/ listener, listener notification but with same result.

Thanks in advance,
n23

Hi,

please check if the unicode settings are correct on the SAP System.
Additionally check if the listener notification is pointing to the correct IDoc Type.
Did you check the IDoc data in the Transactions view in the Adapter.

Which SAP Adapter version are you using?
Are the latest Fixes applied to the Adapter?
Do you have the latest JCo Library version installed?

Regards,
Holger

Hi,

We recently migrated from 9.9 to 10.7 and on 9.9 it was working without any issues.
The listener notification is pointing to the correct IDOC Type (we checked this together with our SAP team). Unfortunately I am not getting the IDOC body as I think that in case transactions are Rollbacked the body is not saved.
We are using SAP Adapter version 10.1.0.5.1046 (fix level: SAP_10.1_Fix5) and we are also using the latest JCo Library version.

Br,
n23

Latest JCo Version I am aware of is JCo 3.1 Patch 4 with JCoIDoc 3.1 Patch 1.

Another option is to clear the DDIC-Cache for this DocType and recreate the ListenerNotification with a fresh lookup of the DocType.

Regards,
Holger

We are using CI+CD pipelines so we cannot recreate it directly on the upper environment.
I will try to do this on dev and then trigger the pipeline for the test env (at the moment the issue was detected on the test env).
Will get back to you with the results

n23

Update: It is still not working :expressionless:
I really do not know what else is to be checked. It does not make any sense at all.

Hi,

can you provide a larger snippet of the server.log with this error message please.
Also share a screenshot of the About page from SAP Adapter.

Did you check that the program id and IDoc Type are setup identical on dev & test SAP instances?

Regards,
Holger

This is what I can see in the server log:

2021-09-22 13:20:40 CEST [SAP.0110.0009I] (tid=84229) Inbound tRFC: Executing TID 0AD000D40460614B11870001 for IDOC_INBOUND_ASYNCHRONOUS from "Adapters.SAP.listeners:listener_XXXXXXX"-WEBM_XXXX-sapApplicationServer
2021-09-22 13:20:40 CEST [SAP.0114.0002I] (tid=84229) ALE:InboundProcess - Message sent to Routing Listener. 
2021-09-22 13:20:40 CEST [SAP.0115.0014I] (tid=84229) Notification - No routing notification exists for msgType: XXXXX (SNDPRN >> RCVPRN) in list of 155 registered notifications. 
2021-09-22 13:20:40 CEST [SAP.0110.0004I] (tid=84229) ALE:InboundProcess - Rollback 0AD000D40460614B11870001 
2021-09-22 13:20:40 CEST [SAP.0106.0004W] (tid=84229) Error in inbound call for IDOC_INBOUND_ASYNCHRONOUS from sapAlias: com.wm.app.b2b.server.ServiceException: [SAP.111.9506] WmSAP Adapter: Missing notification - MsgType: XXXXX (SNDPRN >> RCVPRN). 
2021-09-22 13:20:40 CEST [SAP.0104.0005W] (tid=84229) Error in RFC Listener Adapters.SAP.listeners:listener_XXXXXXX with status "ALIVE" and connection "4-sapApplicationName|sapgw00|null|null|null|null|null|WEBM_XXXX": com.wm.app.b2b.server.ServiceException: [SAP.111.9506] WmSAP Adapter: Missing notification - MsgType: XXXXX (SNDPRN >> RCVPRN).

Yes, the setup is identical on dev and test SAP instances

Br,
n3

Have you tried refreshing (disable & enable) the notification and listener, in the right order? Try reloading the WmSAP package after the refresh.

Can you compare the contents of this file against a pre-upgrade backup if you have one?
Is this file empty on your 10.7 setup?

File - \packages\WmSAP\ns\wm\sap\internal\ls\routingListener\node.ndf

KM

I solved it in the meantime.
It was because no value was provided for Cim type in the ALE listener notification (on 9.9 this was working, it seems that on 10.7 this needs to be provided).
In order to solve it I had to create some bogus routing notifications for capturing the whole IDOC body and took the value for the Cim type from CIMTYP.
Thanks a lot for your hints :slight_smile:
Br,
n23

1 Like

I will have an eye on this during our upcoming migration from wM 9.12 to 10.7 as not all of our IDocs have a CIMTYP available currently.

Regards,
Holger